Apple Mail MacOS redirect function broken?

I try hard to keep my work email separate from my personal email. But sometimes people send emails to a personal account that’s actually work-related. When that happens, I’ve been able to use the “redirect” function in Apple Mail on the Mac to get it into my work account and deal with it there.

(I use Outlook and an Exchange account for work and Mail for personal stuff. Having separate apps helps keep me from answering work emails when I’m supposed to be taking time off.)

But for the last year or so, when I try to use the redirect button I get an error that says “The server response was: Not authorised (sic) to send from this header address”. It doesn’t matter if I use Fastmail’s server or iCloud’s, I get the same error.

Googling the matter tells me that there are others reporting the issue, but no one has posted a solution that I’ve seen.

Do any of you have an idea what’s going on? Thanks.

It sounds like your server is not allowing the redirect. If this is the case there is nothing you can do. Only your email admin could change this behavior. If you set up your company mail on you can drag messages from one account to another.

From the Fastmail web interface, I can “forward as a copy,” and it behaves the same way “redirect” did in the Apple Mail app. (I’m trying to redirect via the Fastmail server.)

So I guess the point is that I can do it from a web interface and not the Apple app. That seems to be a bug.

EDIT to add additional info;

I tried to redirect a message in my iCloud account and that worked as expected. So it appears that the issue now is with Fastmail. I’ve filed a report with Fastmail support.

1 Like