Apple Mail print to PDF: no content included in Apple's e-mails

I regularly “print” e-mail receipts (e.g. costs for software) as PDFs (of course using MacSparky´s clever shortcut) and let Hazel do the filing and sorting or start some sort of other automation.
This does not work with e-mails sent from Apple (!) e.g. iCloud bills - apart from the header the resulting PDF is empty. The only option I found is to print the e-mail from iOS or iPadOS - then the resulting PDF looks perfect.
Does anybody else have this problem or any idea what causes this behaviour?
Looking forward to your ideas, Best regards from Germany, Martin

I had the same issue with and found changing the paper size would fix it (from A4 to US Letter). I never figured out a permanent solution but have switched email clients since.

I have no idea. But if @onepointzero 's suggestion doesn’t work out I’d look at Apple’s email privacy settings. They cause problems on some websites so perhaps they are effecting your email?

I just tried it on my system, and it worked without any sign of a problem, also with A4 as setting for the Papersize.
What are your settings during the “print”? Is there anything “special” set?
Could you print it with a regular printer with the same settings?
Could you open the “Print” from the “Printmenu” (lower left pulldown menu) with Preview?
What are your settings under Mail → Preferences → Privacy (Far Right Tab)? (I have activated the first choice, the last two are grayed out, and the last of these is empty)

No, indeed that can be a problem - but not in this case. Thanks, M

No, that doesn’t change this behaviour.

1 Like

Thanks, but I already tried all this…

And what was the result?

Sorry: No change. No problem on iOS, on Mac OS still no content in the body of the e-mail (neither in the resulting PDF nor in an actual printout on paper).

OK? But you could see the content in the Body of the Mail, so it is downloaded?

Yes, on screen it looks perfectly fine - it did download.

This is a very unusual behavior, as far as I could judge this. Normally you should be able to print, what you see.
I have tried to replicate this this afternoon for some time, but did not get that result.
Do you have any other PDF-App on your system, that you can try to “print” to, and see if any of these could produce the image?
Is it really only Apple-Mails, that are not working, or are there more Mails with that behavior?
Is the Mac your private device, or are there maybe some restrictions by your company, if it is a business device?
Have you tried to open a mail, and print it then from the printer symbol at the page header?
If you call up the printer menu, there is a view of the mail on the left site, does this shows the content, or is this also empty?
Within the print menu, there is within the pulldown menu at the lower left side also the option “Sent via Mail”. If you use this, it should open a new Mail, with the content of the Mail as PDF. Is this also empty?

Dear Ulli - thank you for digging so deep! Since I already deleted the last Apple invoices from my mailbox, I can’t yet try these suggestions. But I will when the next one comes. I’ll report back.
And this really seems to be restricted to mails from Apple. Concerning the question of restrictions (one of my Macs is indeed managed by my employer) - I’ll try again if there’s a difference between them.

1 Like