Apple Mail Slow to Open on One Computer

Try doing a rebuild of the mailbox.

2 Likes

Do the machines have the same settings regarding analytics provided to Apple?

thanks I am trying this now.

Good question - how can I double check those settings - I forgot where they are?

Looks like this is fairly common - I am trying some suggestions here…

https://discussions.apple.com/thread/253948365

I’m on a M1 MacBook Air, and I also experience slow startup of the Mail app. Mine takes anywhere from 1–2 minutes to open. After that, the app is responsive and works well, but it sits and pretends to beachball while opening. I’ve tried a bunch of “tricks” to get it to work, but nothing ever seems to fix it. However, I do feel like it has to be a software bug somewhere. It just started in the last few months. Typically I’m using MailMate though, so it’s never really an issue.

3 Likes

I have the same issue. I thought it was related to GPG Tools, since it showed up a couple weeks after installing it and some other users have mentioned similar issues, but removing GPG Tools had no effect, and there’s no GPG Tools bundle as mentioned here.

I tried removing all accounts and re-adding them twice, the second time I deleted everything in ~/Library/Mail before re-adding my accounts. And I tried to turning off iCloud Private Relay in Mail’s privacy settings, based on how Safari has issues with it enabled sometimes. No dice.

I have zero plugins or Mail extensions.

Using an 2021 14" MBP.

1 Like

so I rebuilt one of many mailboxes

had several thousand items - and when it got near the end it crawled about 1 every 5 sec - super slow.

I called the 3rd party email service - they said server was fine - even rebooted and no change

  • next I booted in safe mode - mail still slow 10 seconds to start up (1 sec on other machine with same settings)

  • next I just re-indexed the mail

  • still no change after - 10 secs to start up mail

On monetary 12.4

forums say might be same on 12.5?

I will try to rebuild other mailboxes too

Any more ideas?

also I did some of this…

This also occurs for me, and I’ve seen it on both my home and work laptops. Deleting all the attachments with CleanMyMac helped speed it up a bit it is still around 10 seconds to launch.

1 Like

Thanks for the help Rob

1 Like

_ also I just disabled ALL my accounts - and still no improvement.

BTW: to be very specific:

  • when I open apple mail - the icon shows up instantly
  • but the Main Message Viewer takes 10 seconds to appear (even after all the steps I mentioned)

I’ve seen the exact same thing with my Mac Studio. I think it’s always been like that since I migrated, but it might have been faster in the beginning.

The application seems to launch instantly, but it takes at least 10 seconds for any windows to appear (Message Viewer or individual messages I’ve left open in their own window). It’s annoying, but it doesn’t seem fixable and it doesn’t seem like it’s damaging data.

Edited to add: I’m not running any Mail plugins/extensions.

I had forgotten about plugins, thanks.

I had a DEVONthink plugin that was actually disabled. I enabled it, restarted mail, then disabled it again, and now Mail (for now) launches lightning fast.

Related? Coincidence? No clue.

2 Likes

AHA good Catch - I will try same thing!

1 Like

DEVONthink plugin - can you tell me which one? (I bought DEVONthink but haven’t done much with it yet - I want to do whatever you did to see if that fixes things also)

I have the DEVONthink plug-in and i tested it enabled and disabled. Made no difference with Apple Mail performance.

If the version you have is not up to date with macOS that may be a different matter.

1 Like

YES YES YES - YOU NAILED IT!!! Ha Ha! :smile:

Seem I had the same general issue. What I did was:

  • update DEVONthink to latest
  • activate plugin
  • open mail
  • then deactivate (will activate when needed)

!!! YIPPEE - NOW BACK TO INSTANT ON!!!

1 Like

yes - mine was out of date - great after update - back to speedy!

2 Likes

I can confirm that enabling and disabling plugins (in my case Letter Opener) made Mail launch instantly again. Thanks to everyone on this thread for identifying the issue.

3 Likes

Wow… well you all solved my issue as well. Turns out mine was the BusyContacts plugin. Removing that from the Mail plugin’s folder in Finder, and now the app opens instantly. :raised_hands:

1 Like