Apple Pay/beta- not working


I’m thinking someone here can help me or tell me who to talk to.

Weeks ago I signed up for the public beta for iOS 17, I downloaded the profile and it was on my phone waiting for Apple to release it whenever they do. I never installed the betas that were waiting there for 16. Something also Apple Pay was working with no issues.

Then a couple days ago I decided to delete the beta profile cause this is my primary phone. So I went and deleted it. But it wouldn’t actually delete, if I went to settings software update I would still see the beta there. I looked online and it says I have to reset my iPhone so I went to settings , general, reset iPhone on the bottom and I rest it. Then all of a sudden the beta I’d still there and now I can’t use Apple Pay at all, I have four cards linked to Apple Pay and non of them worked, I tried to add them again and then it says contact your bank. I called my bank TD Bank and they said it shows active on there end and there were no fraud alerts, I was on the phone with the fraud department and they seemed to think it’s Apples problem because I have 4 different cards from different banks not working. Which I agree.

I talked to numerous people at Apple no one can figure it out, one guy I talk to told me it was the banks problem, a lady I talked to told me when it says contact the financial institution they mean green dot bank not your own bank. And one guy who was a level 2 advisor told me that I have to hook my phone up to a computer to delete the profile. He also said it’s connected the issue with the Apple Pay and beta, and also came into my phone and say something and was like yeah the beta is there still. He sent me an email of what to do and I plugged it in the computer and took a while finally got the beta to go away, but no one can figure out why my Apple Pay isn’t working. Does anyone know how to fix this or who to talk to?

Sorry for the long post but this is really ticking me off.

Also I’m using an iPhone 12 Pro Max with the latest iOS

That’s weird, because there are no beta profiles for iOS 17 (only for 16 and below):

How did you do this? From which source?

(I hope you did not got tricked by some criminal)

iOS 17 developer betas (and all other OS developer betas) are available to anyone with an Apple ID, you just need to accept the licence agreement at (if you’ve not done that previously) and they will show up under software updates in Settings.

As beta profiles are no longer used OP should really clarify whether they have just switched on betas in software updates or installed some sort of a profile (which would indeed be fishy).

It is best not to experiment with betas (especially developer betas) on your main device.

Do you have a backup and can you try rolling back to iOS 16? It’s not clear from your post whether you’re still on iOS 17 and Apple Pay is not working or you’ve successfully downgraded to the latest iOS 16 release.

Also, you might want to report the issue to Apple using the Feedback app.

I’m still on iOS 16, I was never on 17. I did have the option for 16. Something which is in beta but I never downloaded it.

This is what I signed up for….

Apple was calling it a beta profile, that’s why I was calling it that.

Apple Pay still isn’t working.

This is what I keep getting for the cards when I try to re add them to Apple Pay.

I had the same issue a while back, and it was an issue with the bank. I was unable to activate any of the cards I have with them. Calling the bank helped, and there was an issue when Apple Pay talked to the bank in how the bank systems responded (there was a phone number mismatch apparently, and Apple Pay does check for that), resulting in the same error message you are seeing.

I’d continue talking to the bank and not mention that you are running or intended to run any beta software, as they will dismiss the case based on that.

I’m on the latest 16 beta and my Apple Pay here in Norway with Nordea is also not wrorking. Contacted the bank and they say all is good on their end.

Would be happy for any clues.

Thanks, so far no fix. I’m thinking it’s a big with the newest update. I did get rid of the beta.

Yeah on my end the bank says I can see it and it’s active on your account. Everything is good on the banks end. But I’m going to ask them if maybe they can remove it from my account and then I will try to re add it.

That is what I have done (canceling, and then adding Apple Pay again) now and it works again.
I was really annoying to carry around my card again.
Didn’t even know my code anymore, haha.

I got a new debit card, can’t add it on my phone, but I can add it to my watch on my digital wallet. No one at my bank knows what’s going on, and no one at Apple knows, they just keep blaming each other. I just want it fixed.

Hi - where did you cancel apple pay exactly???

I think it was just deleted, I think that’s what he meant by canceled.

I know when mine had trouble I waited a month and it started working again. I think it finally cleared out of the apple and bank computer systems.