Apple TV 4K Static Screen

I’m tearing my hair out with this and would love some help.

My gen 1 Apple TV 4K, which is about 15 months old, barely works any more. It often wakes from sleep and just displays a static screen (like the classic white noise TV screen, but in 4K). If it doesn’t display a static screen when it wakes up, it usually will when I click on something to watch.

The static screen seems to be triggered by a change in content, i.e. going from SDR to HDR, or 1080p to 4K.

Here’s everything you might think the problem is, and how I’ve ruled that out:

  • HDMI cable: I have tried numerous HDMI cables, including the 4k 120hz cable that came with the PS5. The cables are all good, and they work fine with our other devices.
  • You might think it’s the TV. The TV is only a few months old, and this HDMI port works for everything else, so that’s not it.
  • We plug everything into the receiver, so it could be the receiver, but the receiver is also brand new (as of November). It doesn’t display any issues otherwise, and is 8k capable, so it can easily handle the 4K 60hz Apple TV requirement. It supports Dolby Vision, Dolby Atmos, the works. (We have a home theatre.) The receiver isn’t the problem either; I’ve tried everything. In fact, we get no video or audio when I see the static. If we got audio, but not video, I’d know the problem is the HDMI cable to the TV, but in this case, I can even rule that out.
  • I thought it might be HDCP issues with the receiver or the TV, but I don’t think this is the case. We have a 4K Blu-ray player. If I pop in a Blu-ray that jumps from SDR to Dolby Vision, or from 1080p trailer to 4k content, this is a non-issue. It just works. (A phrase I wish I could still say about all my Apple devices.) Not to mention the fact these 4K Blu-rays have so much DRM that they could cripple any inferior HDCP setup. So I don’t think it’s an HDCP issue.
  • Finally, you might think it’s electrical interference. We just bought this house last summer and discovered after moving that the basement wiring was a huge fire hazard. So I ripped it all out and re-wired the whole basement myself, then had a certified electrician come and sign off. There should be no interference issues.

So I’m at a loss. Do I have just a lemon? Is there something I’m not thinking of? I’ve heard that you need “insulated” HDMI cables with the Apple TV to prevent Bluetooth issues, which is possible, but I find it hard to believe that the much-ballyhooed PS5 HDMI cable isn’t insulated (and don’t know how to tell if it is or isn’t).

But most importantly, this worked flawlessly for almost a year. We’ve had other issues with this Apple TV, and Apple told me to reset it to factory previously. My assumption is that I’ve got a lemon. But if it’s not a lemon and I can save myself $200 on a new one with a simple, guaranteed fix, I’d prefer that.

Please just don’t suggest more HDMI cables, unless you’re 100% certain some fancy HDMI cable will fix this problem. I’ve been down that road and so has my wallet, sadly…

Did you try this?

There isn’t anything that can really break on them, so not sure how it could be a lemon. A corrupt tvOS install maybe?

Only thing I could think of is that the Intel chip or whatever that controls the HDMI stuff is busted. I guess I could try another factory reset? But I’d be doing one of those ever three months at this rate, and that sucks.

I can now confirm the reset does not work. The TV displays a whole new kind of static screen and it’s frozen and unusable.

Solution: I will throw this thing out the window of a moving car and get a new one, I guess.

Don’t do that, trust me you’ll miss it.

Don’t do that either. Buy another if you must, but if it has the same problem that will point to something else being the likely problem. And don’t forget to return it within 14 days.

4 Likes

You are correct on every count. It could very well reproduce itself in another unit. But it’s been happening for months and I can’t figure out what it might be.

If it was HDCP, you’d think it’d be reproducible elsewhere in the chain somewhere. But I can’t get it to happen with anything else. Ps5 works fine, Xbox works fine, Blu-ray player is fine. I’ve tried different HDMI cables to no avail. A cable will work fine with everything except the Apple TV. A cable is high bandwidth enough for 4K 120hz, but not the Apple TV.

Unplugging the HDMI cable during one of these fritzes and plugging it back in sometimes fixes it, but it’s inconsistent. I can reliably make this happen on wake from sleep, or when I go to watch anything in Dolby Vision. If I disable HDR, the problem seems to go away.

But it returns as soon as I re-enable HDR, and in that case, the problem occurs even with SDR content.

So yeah, there’s a handshake problem, but it seems like it’s on the Apple TV’s end, and not mine. But it completely screws up the whole chain. Even trying to launch my receiver’s settings during the static setup screen results in another static screen.

So I’m just at a total loss.

I have a solution:

After months of trying to figure this out, I dove deep into my receiver’s settings tonight and found the HDCP menu. From here, I’m able to hard-code the HDCP settings for each individual input on the receiver.

By default, HDCP is set to “Auto” for every input. But you can assign it to be whatever you like. I hard-coded the Apple TV’s HDCP to 2.3, and that immediately fixed my problem.

This issue started around January. There’s nothing in my setup that changed just before that time to suggest that was user error on my part. Given that, and given the fact that “Auto” works just fine for virtually everything else plugged in to my receiver, and given the fact that “Auto” worked fine for the Apple TV until earlier this year, I think this is a recently-introduced bug in tvOS. It seems like SDR and HDR content has different HDCP levels in the Apple TV, but televisions and receivers expect each device to have a consistent HDCP version number, rather than a changing one.

I am so happy this is resolved. My day job feels like all I do is fight with computers and people. The last thing I want to do when I want to watch an episode of Parks & Rec after a long day is fight with another computer.

In conclusion:

  1. I am glad this is resolved.
  2. Does anybody know where one could report a tvOS bug?
2 Likes

It started around January? It wouldn’t be the first time an update changed some settings.

Well, it definitely started after December 13, 2021. This didn’t happen until sometime in the new year. January 26 sounds about right to me, or thereabouts. It’s been roundabout two months of this, definitely not more than three.

This checks out.

Edit to add: it was definitely 15.3. I just remembered my Home app on my phone has had issues connecting to our Lutron lights since 15.3 (again, no idea why), and I remember thinking it was odd that the Apple TV should start acting funny around the same time.

1 Like

So probably nobody cares but me, but here we go: my issue is no longer resolved. It started happening (again) today when we took a lunch break.

This time, I got a little more serious about it went through Apple Support on the phone. They confirmed I’d done everything they would suggest doing, and the next steps were to try the Apple TV on a different TV, or (if I don’t have another TV), bring the Apple TV in to the store. I’d probably end up buying a new once, since the unit is just out of warranty and they don’t typically do part replacements with Apple TVs.

This made me think, though: I had one more option.

So I took unplugged the Apple TV from the receiver and plugged it in directly to the TV. Then I set up eArc for the TV and receiver on that input. Now, things seem fine.

This doesn’t necessarily confirm anything is wrong with my setup. I haven’t changed any cables. All I’ve done is move the Apple TV from the receiver to another input.

My suspicion is that the Apple TV has HDCP issues, where it might struggle to send a handshake connection to a receiver, then a TV. So I started googling for HDCP issues with Apple TVs and, well, this could be a bingo. Lots of issues with HDCP and Apple TVs, particularly with receivers (to the point where I found an old Denon knowledge base article suggesting folks plug Apple TVs right into their TV and use eArc, like I’m doing).

I’m not confident this is resolved. My issue could start again at any time. But if anybody else on this forum ever has issues with their Apple TV setup and happens to have the Apple TV plugged into a receiver, this could be part of the issue. Unplug the Apple TV from the receiver, plug it into the TV, and set up eArc.

This never happened with my third-gen Apple TV, but HDCP was much less complex back in the 1.4 days. I think this has to do with CEC and its associated features adding delays that create HDCP 2.2 issues, but since you can’t disable HDMI CEC on the Apple TV, there’s no way to know for sure.

Edit just to add: this actually isn’t the first time this week that I’ve encountered issues with an Apple product, its HDMI implementation, and HDCP. This past weekend my father in law plugged his 2019 16" MacBook Pro into his Denon receiver, via an HDMI dongle that Apple sells in their store. He just wanted to watch a movie with good sound at their cottage. Turns out the HDMI dongle actually declares itself as a DisplayPort device, rather than HDMI, and Apple’s HDCP protections for DisplayPort are stricter or something, so only the left and right audio channels of the movie he rented on iTunes worked. He got all the music and sound effects, but no dialogue. Fixing this required grabbing an old pre-Touch Bar MacBook Pro that my brother-in-law had and using the dedicated HDMI port, which didn’t have the most recent HDCP version control built into it.

So what I’ve learned in the past week is that HDMI isn’t really something Apple is good at.

How about the receivers firmware? Maybe an update?

Just guessing here. I switched to Sonos so I wouldn’t have to deal with a receiver anymore. My receiver had older HDMI ports that I think caused issues.

It’s absolutely, beyond a shadow of a doubt, nothing to do with anything related to the receiver’s capabilities. It’s a 4k/120hz (or 8k/30) beast with Dolby Vision, Dolby Atmos, VRR, the whole nine yards. Software is fully up to date. It’s a 2021 model year Denon, just bought last year. The Apple TV worked just fine on it for months.

Edit: It isn’t necessarily the receiver’s capabilities, but it honestly could just be that it adjusts to each new signal type the Apple TV sends out, tries to pass it to the TV, the Apple TV stops sending a signal or thinks it’s taking too long, then doesn’t fully send a signal. There’s only a 20ms window for an HDCP handshake to work, and if it takes longer than that (which it will with the Apple TV, because the Apple TV isn’t really interested in quickly sending signals in my experience), then that’s where the issue lies.

Which is why I assume it’s an HDCP problem, related to owning a receiver, but not related to the receiver itself.

1 Like

Well thank you for helping me fix the same problem I had today! Gearing up to watch Obi Wan and updated the my ATV to 15.5.1 and then I saw Dolby vision wasn’t working. I don’t know if it was the update or not. Connecting the ATV direct to my TV worked fine but through the denon it doesn’t. Yes it is on enhanced and other settings are correct (as far as I know). Had to plug the ATV into 4K HDMI input 4 and use the eARC for denon audio. Got it working, but this is not a long term solution. Please help.

ATV 4K 2nd Gen
Denon 4700
Sony 85 X95J
All SW / FW are up-to-date

1 Like

Going to chalk this up to either Apple, Denon, or Sony. Glad to know it’s not just me.