Apple Watch doesn't ring

Ever since iOS 14/WatchOS 7 my watch will not vibrate/buzz when I get a call unless I restart my phone. Once I restart my phone it will work for a bit. I think it works until my watch is out of range of my phone for the first time and then it doesn’t reconnect, but it’s ONLY for calls. Watch Control Center shows that it’s connected to my phone and everything except calls works as expected. This is a problem as I have a LTE watch that I regularly use without my phone.

I’m reasonably certain it’s not the phone or the watch as both have been recently upgraded, but this problem was happening in iOS 14/WatchOS 7 before I got the new devices.

1 Like

Have you tried unpair then re-pair (restart phone in between). Fixes many little glitchy things


I have been having the same thing quite regularly. Restarting the phone and watch worked for me at least once, but the issue returns. Do you have CarPlay by any chance? I do, and I read a number of threads (on reddit perhaps) that suggested it is an issue after disconnecting from CarPlay. I will see if I can find the threads for you. At this stage, I am basically living with it and hoping it gets fixed by an update.

YES! That may be it! I do have CarPlay… it was ringing fine after a full unpair/re-pair and now, after driving in my car, it’s no longer reading. Good thing I never drive anywhere :smirk:

1 Like

I feel like this has been fixed since my WatchOS upgraded a few nights ago. Used CarPlay on the way to work as normal, then have received several calls today and they rang on the watch as well as the phone. Worth giving yours a go and seeing if you have any luck!

1 Like

Was this the update for series 5 and SE?

Yes to the Series 5 (that’s what I have), with an iPhone 12 Pro.