Apple Watch unlocking Mac - multiple users

I have a Macbook Pro and Apple Watch unlock works every time without fail (well 99/100). However I’ve always had trouble successfully unlocking my iMac with my watch.

I have just noticed a pattern. If the iMac is logged into an account other than my own then subsequently sleeps/is locked, when I wake it and select my account it attempts to unlock via Apple Watch and always fails. If it sleeps from my account then I wake it, it always unlocks.

Anyone else seen similar behaviour? Both Macs running 10.15.5 and watch v 6.2.6.

1 Like

I have a 2018 Mac mini, and after upgrading to Catalina my Apple Watch unlock had a perfect 0/100 record until the 10.15.5 update. When my watch vibrated and Mac unlocked the first time I had a brief “WTF” moment. Currently, I would estimate it works 75% of the time.

Up to now my opinion of Watch unlock, like that of iCloud, has been “this would be great if it worked all the time”. I hope someone can help you with this. But even with the glitch, it is more reliable for you than me.

It has to be pretty close to my MacBook Pro in order to work but its really quite good there, since the feature came (although at the beginning it would seem to turn itself off in System Preferences). Its just the multi-account iMac that is causing it to fail. Therefore its not a hardware issue but software. Probably something that hasn’t been properly tested at Apple. I guess I should send feedback about it.

1 Like

I can only speak for my iMac (single user) and Series 0 watch (yes, that old).

The feature works flawlessly, sometimes I have to hit escape to exit the password prompt but then hitting space will wake again and login via the watch.

Couldn’t live without it.

1 Like

I’ve had the same issue on the same hardware, to the extent I turned it off - only updated to 10.15.5 this morning though, so will perhaps renable it to try again.

I also see the same behaviour.

Watch unlock works the vast majority of the time on a single user MacBook Pro, but fails on a multi user iMac after other users have logged in and then put it to sleep.

Only way to reliably get it working again seems to be a restart.

I think it’s been that way since watch unlock was introduced.

1 Like

same issue here… you solved?

No change in behaviour as Catalina has been updated. I’m not running the big sur betas on either of my Macs. Anyone who has can report on any improvement in Apple Watch unlock reliability and or unlock screen improvements in general?

I’ll probably update my iMac as soon as it’s released and report back.

1 Like

i try the beta on external drive… and the trouble is the same

An update - seems that WatchOS 7.4 improves this dramatically. I guess the work done on iPhone unlock has also squashed some of the bugs for Mac unlock as well.

When I do a fast user switch to my account, my watch vibrates and it enters my password!


1 Like

This has been driving me insane over the last year. My wife and I share a MacBook Pro and neither of our watches unlocked the Mac consistently. We’d try resetting the option and it’d work for a short while, but would always just stop working (as in, the Mac wouldn’t even flash the message “Unlocking with Apple Watch…”). Then a couple of weeks ago I stumbled upon this:

Immediately disabled fast user switching on the MBP and guess what? Our watches now consistently unlock the MBP. Go figure…