Application icons replaced with generic icon

When I turned on my iMac this morning about 25% of the application icons had been replaced by this generic icon. Many of them are stock apps like messages, photos, etc. but there are quite a few others as well, 2do, Deliveries, etc. I tried restarting, restarting in safe mode, and the ugly generic icons remain! Any ideas?


CleanMyMac can probably take care of this.
It’s a good tool to have for general maintenance tasks, getting rid of crufty old files, etc.

Rebuild Launch Services.

This is easy to do with the free Onyx utility.

1 Like

Thanks for all the suggestions. I was initially very hopeful since I have CleanMyMac as part of my SetApp subscription. So, I could follow both John and quorm’s advice by Rebuilding Launch Services from the CleanMyMac Maintenance setting. Sadly, it worked at it for awhile and indicated it was rebuilt but nothing changed, even after a re-boot. Grrr…I’ll try onyx next I guess.

I’ve had this happen a few times - mainly with Skype. I fixed it manually…or just waited for the next update.

To fix the icon manually (this is from memory, and it’s been ages since I’ve had to do this)

  1. Find a suitable icon - if it’s a common program there’s probably something suitable online.
  2. Open the Applications folder in finder, find the application and Cmd-Click on it. Select Get Info
  3. In the Preview section of the Info window you should see the application’s icon, but won’t because it’s broken. Drag and drop your downloaded icon into the Preview section of the info pain. I’m pretty sure you should now have an icon for your application.

I think there is some corruption in the cache for icons. You can either use Onyx, as mentioned, or boot in Safe Mode. When you boot in Safe Mode these caches are also emptied.

Onyx will indeed fix this!

Thanks for all the suggestions everyone but nothing has helped. I’ve rebuilt launch services with Onyx, CleanMyMac, MacPilot, and a terminal command. I’ve also done every one of those things from safe mode, rebooted countless times, and nearly pulled my hair out in the process. Interestingly, now that I’m done with all that, the problem remains but the applications with generic icons are different. As an example, with my first post Messages and Photos were example of apps with generic icons. Now they’re correct but Chrome, iTunes, Maps, One Drive, and many others have the generic icon. Here’s a picture of part of my dock but it occurs in the application folder as well. So frustrating!

I have this problem, which started after installing the latest macOS beta. I got most of them back by removing and then adding them back to the dock. But Keynote, Pages, Numbers, and FeedBack Assistant still won’t put their icons in the Dock. Suspiciously, these are all Apple apps, so reported and expect them fixed by the next Beta (probably next week). If you are running the beta, perhaps that is the problem!

Note that if I log into an alternate account, the icons are fine!

maybe you can try a reinstall of macos?
I had the issue on High Sierra as well last year, and did a reinstall from recovery mode.

this artcle also has some more pointers.

Did you ask Apple? Their Support app on iOS is very good.

When you launch them they’re in the dock, yes? Just “Keep In Dock” once they’re there via right-click menu.

1 Like

Ah, yes!! But I needed to completely remove them from the dock first.