Backing up Mac to Synology NAS

Backing up my iMac Pro (10.15.3, 1TB) to my Synology (DS918+, 16TB, 8GB, 2GB cache, DSM 6.2.2-24922 Update 5) is problematic. They have a wired ethernet connection.

TimeMachine frequently failed (the exact errors are lost to the mists of time), so I started using CarbonCopyCloner to back up to a folder. This presented problems, so I started backing up to a disk image. When I begin the Clone, it works for from 30mins to 9hrs compacting the destination disk image file, then says:

macOS failed to mount the destination volume because its filesystem is damaged and cannot be repaired

I’m contemplating trying ChronoSync, which I also own.

Interestingly, my MacBook Pro continues to do TimeMachine backups over WiFi without any problems.

  • What do you all use to back up to your NAS?
  • How reliable is it?
1 Like

I have a variety of computers backing up to a Synology DS2419 in the cellar.

Most are using Time Machine, like you, over wireless. Occasionally I’ll get a messaging saying the TM backup couldn’t complete; my work-around is to mount the Synology Time Machine share on the affected mac’s desktop.

For my desktop computer (a 2018 Mac Mini), I’m using a wired ethernet connection and Arq to back up a (large) set of important data. I’m using Arq because I want version control for this data set … another solution I’ve heard about but not tried is Duplicity.

The Arq set up involved using, on the Synology, a docker container and a program called Minio. SInce I’ve got it working there have been no hick-ups with the arrangement (so, since January.)

I looked at CCC but was disuaded because of Bombich’s note about problems backing up to a NAS. I still back up wired computers to an attached USB drive with CCC.

I also considered setting up LUNs as iSCSI targets, but was concerned there would be a significant hit to network speed.

1 Like

Thanks @Timo, I haven’t looked at Arq in a while. It sounds good, and I’ll try the trial.

I imagine the problem may also be what networking protocol you are using. I seem to recall there being some issue with SMB vs. NFS vs. WebDAV, etc. etc.

At any rate, I have reliably been backing up my Macs to my Synology via time machine. I can’t find a reference to the blog post or article I used to set this up, but I think what I did was create a new user on the Synology called “Time Machine”, then I gave that user a quota, then I connected the disk via SMB and used that Time Machine user’s credentials in the Time Machine setup screen. It’s pretty slow in the Time Machine space interface honestly, but it does hold the data and backs up fast.


Chronosync has been solving problems for me for 11+ years. It recently replaced Time Machine which became unusable (unbelievably slow) after upgrading to Catalina.


I’ve had certificate errors for as long as I’ve had my NAS, and haven’t been able to resolve them.
How are you connecting to your Synology with Arq? (i.e. using an IP address like, or, or …)
What kind of certs are you using?
Thanks for any help!

Edit: finally got it working.

It happens, I think it has more to do with the power management of the Mac lossing connection at an inconvenient for Time Machine backup.

It also happens with hard drives falling a sleep before the Mac does.

I ignore these messages as long as I can see a recent successful backup…

I got the certificate issue worked out by creating a cert with my address. It seems to work for using the 10.0.x IP address too.

Installed Docker and Minio on the NAS, and setup Arq to backup up to Minio as an S3-compatible object store. (Turns out I already own a license for Arq.)

Minio looks really robust and industrial strength, and along with Arq seems more dependable than the other systems I’ve tried. So thanks @Timo for those mentions.

Thanks @derekvan, @WayneG, @MacExpert for jumping in too.

De nada, and FWIW I haven’t had any certificate errors.

1 Like

That’s what I’m talkin’ 'bout.

1 Like

For those who might be interested, here’s a link to the procedure I used to install Docker and Minio on my Synology.

As I recall, my experience is similar to @derekvan. There was something hinky where under File Services both SMB and AFP had to be enabled. Unfortunately, like the carburetor I rebuilt on an old Pontiac, and the water pump I replaced on an even older Ford, I only did it once, and it was years ago. That said, I found the Time Machine to NAS to be less reliable than an external HD. After a few months it would just break, not recognize itself, and I’d have to start over. Also, once I needed the NAS TM backup, it was a 24 hr + restore. While I currently Time Machine to both NAS and external HD, I don’t fully trust either and also Carbon Copy Clone to an external drive for dependability.

Been there several times.

Yes, the recommendation is to back up to SMB shares, but AFP has to been enabled for TM to find the share on the NAS.

I think the Arq / Minio combination is going to be a winner.

In the meantime, I discovered that ResilioSync stopped syncing last week. Everything in that folder is on my iMac Pro, and backed up to an external drive, but still, something else to fix.

Should be working on my research. Tired of IT.

Interesting, I’m going to check this out. IT adventures are a welcome reprieve from washing my hands and social distancing.

1 Like

If you use Dropbox, you can use the Synology Backup client to watch some folders of your Dropbox (or all of it) and back them up to the NAS. It goes roundtrip through the cloud but it works very well. I’m using this when I have an unreliable Internet connection and direct downloads / uploads are flaky (Dropbox manages to come through).

1 Like