Backups & iCloud Drive

I’ve made a bootable backup of my hard drive with SuperDuper. When I plugged it in to check the drive, I noticed iCloud Drive is not listed the way DropBox is. Note: I do NOT have optimize Mac storage checked, so all my iCloud documents should be stored on this Mac. I was able to find some iCloud Documents by going to ~/Library/Mobile Documents, but the folder titles are all titled weirdly and it makes me think this is only a last ditch solution.

Ok, no problem, this is a bootable drive, I’ll just hold down the option key and boot from it to make sure my files are there. Then I find this little gem

So, I follow those instructions (restarting with Command-R) and I don’t see Startup Security Utility on the list.

All I’m really trying to do is make sure that iCloud is backing up as expected. This isn’t giving me a lot of hope that if I need a file I’ll be able to recover it. And, I was hoping to have a bootable backup and that isn’t working either.

I tried it again and found Startup Security Utility listed under the Security Menu. However, I’m not sure what the settings should be here.

Selecting “allow booting from external media“
will allow you to boot your Super Duper clone
when holding down the option key on Startup

1 Like

That is where your iCloud documents reside, along with the data from apps you have installed that use iCloud. Folders that you have created in iCloud reside one level lower in ~/Library//Mobile Documents/com~apple~CloudDocs/

The only way I am aware you can see these files in your Time Machine backup is to search the drive using Terminal. I don’t use iCloud or Time Machine and cannot verify that.

Thanks. I have navigated the maze of these folders. The issue is, I have my iCloud organized by project rather than the app that was used to create the document. My project folders seem to disappear completely. So the only way to truly find what I’m looking for is to open various folders until I find it.

What is the recommendation for the “Secure Boot” section? What is Apple really trying to protect us from here?

The intent is to prevent the installation and
operation of operating systems that have not
been cryptographically verified by Apple.

Similar to how the iPhone is “protected”
It’s rather difficult to load anything on the
iPhone without Apple’s involvement

Much easier to do on a Mac…

1 Like

I’m just getting back to this. When I restart with Command-R, I don’t see Startup Security Utility. What am I missing?

Open Disk Utility, click on the drive that hosts the primary OS, and Mount. (If FileVault is installed you’ll need to enter your Admin password.) Once mounted, exit Disk Utility, then Startup Security Utility should be an option.

Thanks @bowline. But it was already mounted. I tried unmounting and remounting. I also tried unmounting and seeing if it appeared after that. I still can’t figure out how to get Startup Security Utility to appear. Here are screenshots of what I’m seeing inside Disk Utility. (FWIW, FileVault is not turned on).

Does anyone know an alternate way to get to the Startup Security Utility ?

Not sure what you’ve done but try to shut down your Mac, wait a few seconds, then start your Mac using common-R. (don’t restart). This seemed to help me. Not sure why; could have been chance.

Thanks @neonate. I tried that a couple of times, but it didn’t change anything. Startup Security Utility still not showing up.

1 Like

What happens when you click on Firmware Password Utility?

A question:

Are you logging in an Admin account and not a lower-security User account? (Since you are required to authenticate as a valid admin user when opening the Startup Security Utility perhaps it isn’t even an option unless you’re already an Admin.)

A couple more:

• If your Mac is not allowed to use an external disk I assume your machine has a T2 chip in it, yes?
• And perhaps you also set a firmware password on the Mac (which disallows booting from an external drive)?
• Is Secure Boot employed?

If you did log in as Admin, and have the firmware password and/or Secure Boot enabled, I’d try temporarily to disable them and see if Startup Security Utility reappears. (You are required to authenticate as a valid admin user when opening the Startup Security Utility, and if the setup assistant has not been run and no user has been created, then you will not be able to open - or possibly see - the Startup Security Utility.)

Well, Password Protection was off. So I got this message:

I turned it on and got this message:

Because it seemed to do the opposite of what I wanted, I turned it back off:

  • I checked, and I am logged in as an Admin when I restart.
  • I assume this machine has a T2 chip because when I tried to boot from my SuperDuper clone I got the message “Security settings do not allow this Mac to use an external startup disk” That message is what started this whole thread.
  • Judging from my screenshot above on April 13, at one point I was able to see the Startup Security Utility (SSU). My memory is that I didn’t know what to do when I found it and I didn’t change anything. For some reason, on the same computer, the SSU will not show up now.
  • I did not have a Firmware Password set. I tried setting it (see message to @neonate above). But it didn’t change anything and I have sense turned it back off
  • Sorry, I don’t know how to check if Secure Boot is employed.

Thanks, all for trying to help me solve this! I appreciate the help.

Startup Security Utility sets SecureBoot to Full Security by default

Since anyone with physical access to the Mac can boot into the macOS Recovery, this provides a safeguard against local attacks and while on prohibits external boot drives from working with Macs. So yes, I think you have SecureBoot on, and I don’t know why you can’t access it (or, therefore, turn it off).

I hope it isn’t related to the issue of corrupted T2 firmware as described in this recent thread - I just don’t know, sorry.

Which operating system are you on? Look at the middle of the second paragraph.
Seems to me that Startup Security Utility is for High Sierra later.

10.11.6 El Capitan

At one point (April post above) I was able to get Startup Security Utility to come up on this machine, but I can’t now.