Big Sur and Time Machine issues

Help Appreciated. My wife has taken delivery of a new MB Air M1 enabled and it is truly great. But it couldn’t seem to back up to my existing Apple Time Capsule. So I did some reading and it seems (depending who you listen to) that Time Capsule needs to be formatted to APFS and others, including Apple, say that Time Machine will update HFS+ automatically. That will enable existing time machine backups to continue to be useful for anyone upgrading to BS.
So I upgraded my beloved 2015 MBP. Now neither of us can get TM to back up to the Time Capsule.
So, I erased the TC and rebooted it, thinking that either computer would offer to reformat the drive to APFS when commencing a brand new backup.
NO luck. All I get is this, and no further explanation as to what may be the problem or the solution.

Thoughts anyone?

Cheers,
Russell.

Time Capsule will remain HFS+ forever, it’s baked into its firmware. That said, I’ve read accounts from other users stating it still works on Big Sur (obviously that’s of no help to you). I don’t have any great advice to give you other than try the whole erase/restart thing again.

2 Likes

Thanks Jec0047
I’ve done that after trying a range of other things and still no luck. All computers on the network happily connect to Time Capsule, recognise it and Airport Utility says all is fine and up to date firmware etc. It’s just Time Machine on the laptops with Big Sur cannot create a new backup.
I’ll keep researching and trying things. see what happens.
Thanks again, Russell.

If anyone is following this investigation. After erasing my Time Capsule and encountering two laptops running Big Sur that cant seem to create a time machine backup, I thought I’d see if my wife’s old MacBook, running Catalina would create a backup.
Yep, no problems whatsoever.

I had an issue where the second account created could not run TimeMachine to back up to a time capsule. It had to be the initial admin that was created during install. I did a clean install of Big Sur.

1 Like

Hi Scotte
Both my wife and I are the admin accounts on each of our computers. But I’ll give that some additional thought.

As @jec0047 mentioned, Time Machine uses HFS+, and if you are experiencing issues with an external, this is probably the culprit. I recently put a year old SSD through the following process, and was able to change it from APFS to HFS+, and got it working as a Time Machine backup for my new M1 MBA.

Time Capsule uses HFS+, and only HFS+. Time Machine can apparently use either HFS+ or APFS (I say “apparently” because I’m still on Catalina so I can’t speak from experience, only from what I’ve read).

2 Likes

Well I’ve read everything I can find and followed Apple’s set up a new time machine disk instructions and have even enabled SMB in file sharing. Still no luck. I can mount, see and even upload and delete files on the Time Capsule using Finder, but TM just will not create a new back up.

You didn’t mention … but a simple thing I noticed with TimeMachine on a relatively fresh Big Sur install. It was looking to be “stuck” in preparing a first-time backup (to a new Synology NAS on my local network). I didn’t know if it was just the volume of data (first-time) or just being ornery. I re-booted the machine, and TimeMachine kicked into action without being prompted. All now well. Have TimeMachine destinations to both the NAS and to a USB spinning disk, and all seems to work fine. Anecdotally, it was the re-boot which fixed it.

1 Like

My mistake. I personally had issues trying to get APFS to cooperate with Time Machine on store-bought SSDs that I purchased for that specific reason, so the solution that I linked was the best workaround for me.

Alas, I have rebooted both my Mac and my wife new Mac and also the Time capsule yet the issue remains (For these two only. My wife’s old Catalina MacBook is happily backing up to TC hourly)

Well that only took about ten days of trying almost everything. Solution, Sophos home premium has a known issue and will prevent a backup to a Time Capsule or NAS.
Me thinks that would have been a handy ‘pop up’ from the App given that it is a web based platform.
Solution - uninstalled Sophos. Time machine works like a charm now with my Time Capsule.

3 Likes

Do you have more information on this? I was able to backup previously but am having issues now.

NM - found it on their website - My original backup must have been prior to Sophos install.

Hi Scotte
Yeah it’s been a torrid week trying to nut this out and it could have been averted by an email to Sophos users or even specifically to Mac users or as I suggested even a ‘pop up’ notification from the app to let us know.
FYI, I initially went through and switched off every setting in Sophos dashboard to start the process of identifying which setting is the offending setting and even with every single setting set to OFF, no back ups were possible. Only a total uninstall restores Time Machine function.
So now we know. Awaiting January when Sophos assumes they’ll have a fix.
Merry Christmas
Russell

1 Like

So I have Sophos installed on my iMac and it backs up fine to my Drobo. I wonder if Sophos is scanning the time capsule drive when it gets mounted by Time Machine and thus is “busy”.

I checked in again with Sophos today to see how they are getting on. It appears they have managed to conquer a few issues regarding web scanning and a couple of other glitches. However, as at January 11th, they have not fixed time machine backups and go so far as to cite the January fix they expected will arrive in March!