Big Sur "break" thread

Downloaded and installed last night…this morning encountered two issues:

a) my Anker “hub” was not powering the MacBook Air like it has since I bought it in August (had to plug power in directly to the 2nd USB-C port and

b) my Apple mouse isn’t working (but shows up under Bluetooth devices and the battery level is there under System Preferences, curiously).

Anyone else having issues? Or had these and fixed them?

Mouse working here, as is Trackpad (both Apple). All my USB hubs (Amazon “Basic” in iMac, and SATECHI and a Belkin Dock on MacBook Pro) all seem to be working.

For a few other “niggles” I noticed, that after a few re-boots (for practical, not debugging reasons), those niggles disappeared. Perhaps try that. Dunno more than that.

Three finger swiping between spaces have a pretty bad lag (1 to 2 seconds) between the swipe gesture and the beginning of motion on the display on my 2019 Air, at least when windows are open on the spaces. Subsequent swipes don’t lag, unless I wait for 20 or so seconds before trying them again.

I noticed lagging. Typing but it cleared up eventually. I suspect the system did some final config in the background and eventually finished. And give it a reboot after giving it time. I have nothing more than a hunch about this.

Rebooting seems to have fixed the mouse. Woohoo!

I am liking the look of Big Sur so far. The square icons are so pleasant to look at for a neat freak like myself.


Let the Big Sur bashing begin…

1 Like

Installed Big Sur as an upgrade on my Macbook Pro. When it was done, it booted to a grey screen. Support could not help and I ended up restoring from my TimeMachine backup, saved some things to a NAS drive, and did a clean install. Then spent a half day installing software again.

Waiting to do my iMac but may end up following the same procedure there as well just in case.

Some broken software and display update artifacts that have been around since the first beta and still not fixed in release. I’m sticking with Catalina or earlier for now, just running a test copy of Big Sur on an external drive.

One “gotcha” I haven’t seen talked about anywhere is the increase in size caused by the Universal binaries and, in the case of the OS itself, the added code to support Rosetta 2. In my measurements, Big Sur is 28% larger than Catalina. The updated, universal binary, apps have also grown. Pages up 26%. Third party app Affinity Photo up 62%. I experimented compiling “Hello World” in Xcode. Switching from Intel only to Universal it grew in size 245%! Since the App store apps are moving to universal binaries, even if you stay with Catalina expect to need more disk space.


After the update, when you connect an external monitor through an adapter, the trackpad starts to go crazy (you put your finger on it, the cursor on the screen starts to twitch and rush around the screen) after turning off the external monitor, everything comes back to normal. There was no such thing before the update. And it happens in periods.

“Mountain” breaks Big Sur in spectacular fashion for me.
Caused a reboot when waking from sleep and then when it’s loaded on startup caused a permanent beach ball.
Admittedly it hasn’t been updated since High Sierra days…

Drobo Dashboard causes system crashes and kernal panics. Initial update install went well, but immediately after reboot crashes happened. Not enough time inbetween panics to uninstall Drobo Dashboard.

Decided to do a fresh install and a.s.a I installed latest Drobo Dashboard it crashed again. This time the uninstaller was handy (part of setup) and after that everything was fine. Now waiting for Drobo to get Big Sur ready to reconnect with my files.

The installer went from 8 GB to 12 GB.

Installed Big Sur on 8 machines so far not a single problem.

1 Like

Once the update completed Drobo Dashboard prompted me to update. I haven’t experienced the problems you did.

It appears my drobo isn’t connecting after a reboot of my mac. I need to replug the USB 3.0 and then its good. Also the UI is really messed up with parts of it appearing transparent. Luckily its not something I need to see much.

I have 4 accounts on my iMac for 4 members of my family. After updating it took a very long time for each account to log in for the first time. So long, that I had to perform a hard reboot, thinking things had hung. After trying twice I thought I would just leave it run and eventually it got there. Subsequent log ins to each account were normal. Now I hear there was an Apple CDN outage and perhaps that had something to do with it. I was going through the upgrade process on Friday late evening PST.

My Apple Watch unlock still doesn’t work as it should but it didn’t really work in Catalina either.

Other than that I’m quite surprised that it is running as well as it is.

1 Like

No issues here except I still can’t get Sidecar working with my 2020 iPad Pro.

Is anyone using ABBYY FineReader on Big Sur? Their website claims it’s “unsupported”. That doesn’t have the mean it’s not working.

As this is still the best OCR engine on the Mac (IMHO, suggestions for alternatives that are on par are welcome), it’s kind of critical to my workflow (scan -> OCR -> automatically file). I have been using Tesseract in the past, but found it wasn’t as accurate as FineReader.

1 Like

The icons in the toolbar aren’t adjusted with the colour, leaving some of them invisible:


I’m sorry to hear this. Do you know of an alternative that is Big Sur friendly?

This isn’t quite what you’re asking, but ABBYY OCR is working in DT on Big Sur (including for me, personally.) However, it apparently will not work on the M1 Macs yet. Source: