Big Sur: keyboard shortcut to remove from finder not working

After updating to Big Sur I can no longer delete files in Finder with CMD+ backspace (on my bluetooth keyboard). Backspace just gives a “beep”. CMD + backspace → nothing at all! I’m forced to use the mouse…

Anyone with similar experience? Any help?

Did you try to have Bluetooth forget the keyboard and then re-pair it?

other than @anon41602260’s simple yet great step —works for some of my windows bluetooth keyboards which reverse the ⌥ and ⌘ key, you might also try:

  1. When pressing ⌘⌫, observe the menu bar. Is there any menu item that flashes when that shortcut pressed? There might be custom shortcut defined in System Preferences → Keyboards → Shortcuts tab.
  2. If you install any keyboard rebinding/automation app (Karabiner Elements, FastScripts, Keyboard Maestro, BetterTouchTool, etc.) try quit and/or disable the daemon service for those app.

@anon41602260 yes I’ve tried that. To no success.

@ybbond 1. No custom shortcuts, I’ve tested.

  1. I tried to shut down keyboard Maestro, and Better touch tools, to no use.
    BUT after restarting my Mac, I cannot use the backspace key anymore to remove characters.

I’m testing my wife’s windows keyboard, attached with a cable, and it’s the same with that. Right now I have to use the delete key on the windows keyboard to be able to correct any characters.

Strangely enough when using the option + backspace it’s working as supposed, removing a word - both keyboards. And Keyboard Maestro is “registering/recognising” the backspace key.

I updated 11.2 yesterday, but I’ve had the same problem since I installed Big Sur som e weeks ago with 11.1

I currently don’t have any solution, but I may know ways to troubleshoot/temporary fix:

  1. troubleshoot: you mentioned you have BetterTouchTools, so try wether BTT also cannot detect the ⌫ key by declaring new Key Sequences / Typed Words. From the result of this, we may know how to act

  2. quick fix: I don’t know whether this will work, but try install Karabiner Elements and kinda “force” so delete key acts as delete.

Great input. You’ve given some very useful information, and opened new perspectives. This is where I am right now:

  1. I’ve mostly used BTT for window manipulation, this was new to me. I tried this

    and the keys seem to register, and they work when I assign an action. But only backspace didn’t work.

  2. Haven’t heard about Karabiner, but tried it, just as you suggested. No difference in using the backspace key. But to my surprise the CMD+ backspace combination suddenly worked in Finder - and elsewhere!!
    Before this test combinations of fn+backspace and fn+OPT+ backspace worked fine. Now even CMD + backspace!

I’ve quit BTT. Tried to quit Karabiner in Activity control (? I use Swedish) to see if anything changes with no success. Why? Do you need som terminal magic to stop Karabiner? Not my cup of tea…

The problem remaining is how to get my backspace key to work as normal.(Fascinating when you realize how much you use it…)

You can quit (and there is option to uninstall too) Karabiner Elements by open “Karabiner Elements” with Spotlight and open the “Misc” tab (2nd tab from right), the button with x inside circle icon is quit, the button with x inside trashbin is uninstall. Here is the official help.

Well at least that indicates your ⌫ key registers. But we’d still needs further research on why single key won’t register.

Odd place to put the quit button:)

@ybbond Now it’s working!

I suspect that Karabiner made the difference. At first the delete key did not work. But then I realized I had some remains of testing key combinations in BTT, and when I removed these, the Delete key suddenly worked.

Thanks a lot for putting me dow that path :clap: It saves a lot of frustration for me :grinning:

1 Like

Glad to hear that :smiley:
I am still looking for possible solution on Apple StackExchange now and then, but I guess you’ve found a temporary/permanent solution.