Big Sur network issues

And yet another issue with Big Sur. :frowning:

As it seems since the 11.2.1 update my 2017 MBP is losing the wired ethernet connection through the Belkin Thunderbolt 3 dock after the system went to sleep.

It took a while to notice this, as Wifi took over the connection just fine. But when I looked in the network preferences I found out wired ethernet was disconnected.

The only way to get it working again is to disconnect and connect the thunderbolt cable to the dock, or to unplug/plug the ethernet cable on the dock.

Is anyone else having this issue? And even better, know of a way to fix this (if possible)?

This issue may also explain why my Teams session got slow when a Time Machine backup was running (mentioned in another topic). It probably was all going over Wifi instead over wired ethernet.

B.t.w. when looking in the console to look for messages that could point me to the root cause of this problem, I also found loads of mdworker related messages. Seems this is a long lasting issue (according to the many posts I found about this on the net).


Same problem here, although I got my new dock just a couple of weeks ago. Never worked reliable.

1 Like

First the battery issue with 11.2.0. Now this (and countless other problems, like the ssd issue with M1 Mac’s). Apple should really get their QA act together.

I have exactly the same issue. The only solution when it happens is to disconnect and then reconnect the dock. This is on a M1 Air.

I hope they fix this soon.

1 Like

It’s a really annoying bug. Basically renders wired ethernet useless.

If an Apple thunderbolt to ethernet adapter is still working I might consider buying that. Everything better than just Wifi.

I’m afraid they earliest fix (if the gods at Apple acknowledge this bug) will be in Big Sur 11.3. Which might take a while…

For the record: I filed a bug report. Hope others will do that too.

1 Like

Whatever they did at Apple, yesterday’s macOS 11.2.2 update did not fix the issue with usb-c/thunderbolt network connectivity. :angry:

Hopefully Apple’s own $/€35 usb-c ethernet adapter can keep that connection. Because just WiFi is not an ideal situation.

And now we’re at macOS 11.2.3 and the issue seems to have worsened. No wired ethernet connection after sleep. No wired ethernet connection after reboot. Only unplugging and plugging in the thunderbolt 3 dock brings back the network connection.

I’m so done with Apple and the lousy quality of Big Sur. Really.

This is not an exotic setup. As Apple decided to remove all ports except for the usb-c/thunderbolt ones on their laptops connecting ethernet through some kind of external device is the only way. Apple doesn’t make usb-c/thunderbolt 3 to ethernet adapters. So one has to use a third-party device. And guess what? That doesn’t work.

Form over function. Thank you Apple.

I meant to start a thread about this, but found this one first. One very strange thing I am noticing with the M1 is that the ethernet connection is simply horrific while the wifi on the other hand is brilliant (less so for uploading, of course).

This is roughly what I observed:

MacBook 2019 Ethernet
>= 210 Mbps

MacBook 2019 Wifi
>= 80 Mbps

M1 Ethernet
>= 20 Mbps

M1 Wifi
>= 240 Mbps

1 Like

I’m having a different issue with my 2015 15" MacBook Pro not recognizing that the Apple Thunderbolt 2 Ethernet adaptor has been disconnected and is still trying to use it. Currently need to reboot to it to use Wi-Fi again. Worked perfectly for all versions of macOS 10.x. macOS 11 isn’t off to a good start.

1 Like

Finally some good news on this topic. Hence an update.

I had the choice of either throwing my MBP out of the window, or try another solution to reliably connect to a wired network. I choose the latter.

So I bought a $20 (including shipping!) GiQ usb-c ethernet dongle. And lo and behold, this thing does what my $300 Belkin Thunderbolt Express Dock HD couldn’t do: keep a reliable ethernet connection. Even after the Mac went to sleep. Or after a reboot.

For the record, Belkin support replied promptly after I tweeted about the issue. And their response was friendly, but completely useless.

Anyway, best $20 spent in a long time. :slight_smile: And if all goes well, I can wait until there is an M1x Mac Mini.

1 Like