Big Sur*prise* this morning

My 2015 MBP is repeatedly crashing on boot this morning (login, “reopen programs” prompt, but locked up, spin, crash) . It was running fine when I closed the laptop the other day. Doing internet recovery now. Very annoying.

Internet recovery is offering to reinstall Yosemite.
Thanks for that.

Apparently, Option+Command+R will install the latest version. We’ll see.



Good luck! I recently removed my OWC aftermarket SSD and re-installed everything on my old SSD. I had to start from Mavericks, (Option+Cmd+R did not get me the latest version).


I have a Fledgling drive, so probably the issue with mine, come to think of it. Thanks for the reminder!

Got the same error after reinstalling the OEM drive and try to internet recover the latest version of macOS.
Nuke and pave with Mojave, then will upgrade to load Big Surprise.

I don’t mind working on my tools on my terms, but it’s super annoying when you’re doing something else and wind up spending that time on your tools.


Same feeling here. I’m putting off the nuke & pave on the OWC drive.

And I’m this close to just buying an M1 Mac Mini… but it would take a month to get it.


I’ve been thinking about an M1 laptop, but don’t think I can deal with the current 13” screen. Also thinking ahead that I should be using it 5 years, and how will my vision be then.


I’m in the same boat as you, John. I feel that 13" is just too small for old eyes. I find myself using the Accessibility Zoom features all the time. Hoping the 16" MBP comes out soon.


I have a 2017 MacBook Pro that has the -5101F problem. In the recovery mode it tries to load Sierra (the machine was on Catalina), but fails every time.

I’ve given up on that machine. Thankfully my working machine is a 2020 MBP, but it’s annoying that without warning my 2017 machine trashed itself and nothing can bring it back that I’ve tried.

1 Like

Might I assume you have no external drive that is bootable? If you can create one, download a MacOS installer, boot from the external, and erase your drive, then install.

Hopefully you have a Time Machine or clone to migrate all your stuff.

1 Like

Now that I’m thinking about it I think I saw that globe & exclamation point a couple of times. Apple says it means that the Mac couldn’t boot from recovery. I think I tried again a few times and got it to boot to an installer.

1 Like

Good stuff! I only use recovery if I have no options. I always have a bootable external that I can use for testing, troubleshooting, erasing/installing MacOS