Bootcamp on iMac with 2 internal drives (not a fusion drive)

Hi all,

I was hoping to get some help with running Bootcamp on an iMac with two internal drives.

As a quarantine project, I recently decided to open up my late 2015 5k iMac and replace the CPU with a Core i7 6700k, the spinning hard drive with a Samsung Evo and the blade SSD with a Sabrent Rocket Q.
The upgrade has worked fabulously; no more kernel panics, which I think were a result of the fusion drive, and it is lightning fast!

I have the OS and running off the m.2 NVME, with the Sata3 SSD as an internal backup, with CCC making regular backups throughout the week. So far so good.

The only issue that I have encountered is when trying to run Bootcamp. Rather than go through the normal Bootcamp process, I get the error: Bootcamp assistant has encountered a problem. Internal error occurred. (Similar to this problem:

I’ve done some research and it seems that this is a well documented and recognised problem when the Fusion drive is split. I love my internal backup, so would be hesitant to refuse the drives or take open up the iMac and take out the SSD, to then replace it once Bootcamp was set up on the NVME.

So, I am wondering if anyone has had any luck getting around this problem?

I tried to do some simple trouble shooting like creating my own partition and Windows 10 USB bootable media, but the installation fails.

Any ideas?


PS. Running Catalina 10.15.5

Never taken your approach and swapped a fusion for 2 disks, but I previously manually installed windows on a partition without using boot camp, that might work around your issue?

It was pre apfs and from memory you press option on startup or I think I maybe used refit for boot options. The option key may pose a problem with a Bluetooth keyboard.

Sorry I know it doesn’t solve your actual issue but perhaps a workaround if there isn’t a fix.

1 Like

Thanks for your input and suggestion.

I tried that method - manual partition, with attempt to boot, but I couldn’t get Windows to install properly. Perhaps a drivers issue?

I am able to download bootcamp drivers separately, so if I can just get Windows to install correctly I’d be home free!

I vaguely remember having some issues when I did it, what problem are you facing?

Thanks for your interest - this is slightly tricky to explain so hopefully I do an ok job.
I’ve repeated this process a few times, with the same thing occurring each time.

Step 1
I start by partitioning my boot drive, adding a 200gb partition in MS-DOS (FAT) format.

Step 2
I then reboot, holding down the option key and selecting the Windows 10 USB installer that I have.

Step 3
I delete the partition that I made earlier so that the Windows installer can reformat it to NTFS.
I then proceed with a Win 10 installation, however, it always fails almost immediately at this point and requests that I restart the installation.

Step 4
I then recommence the installation (all without exiting and restarting the system) and get through the entire installation until this screen pops up:


If I then repeat the process, I get the same issue each time. Interestingly enough though, every time that I repeat the process, a new 100mb partition is made, which I presume is the EFI boot, so perhaps there is an issue there?

I can repeat that process any of number of times, but it never progresses past the screen above.

Any tips? With thanks.

That wasn’t an issue I faced as it was pre apfs I did it but looks like a similar thing to this

He gives a guide to change from a hybrid disk to a normal one, I’m guessing is that bit Windows doesn’t like and you need to play about with.

Make sure and back up your OS X install first!

1 Like