Browsers and preview

I have a fun little problem, if I create a post on and want to preview it I get a 404 with the message that the page no longer exists. This is on my Mac and with Safari, Firefox and Brave. Using Vivaldi it works. I also tried on with Safari on my iPad and this works. So this is something that is local on my machine (but see below) and only affects Safari, Firefox and Brave. I have 1Blocker running (Safari) but tried disabling it, I also have Little Snitch and tried to disable it. But I still have these preview issues. I’ve also tried to clear all data from Firefox and Brave but it still doesn’t work.

I’ve also tried on a second user on this machine, same result. Also with this second user on a laptop, same result. The WordPress people see the preview just fine.

Does anyone have some suggestion for what could cause this problem? What am I missing?

Are you sure you are using the correct URL? Is the correct URL with or without `https://…``?

404 errors mean the link is not correct. It’s broken. So that’s the place to troubleshoot.

1 Like

Yes, this is what’s so strange. I do exactly the same steps in the different browsers (I don’t type the URL manually) and I also tried a link that seemed to work for the Wordpress person

FWIW, I encountered the same problem. One of may reasons I’ve moved most of my personal blogging to Tumblr.

It’s possibly specific to certain themes. Switching themes might help. This is not a practical solution if you like your current theme.

You never found what caused this I assume?

1 Like

Well, I’ll do a quick test with another theme this weekend

Correct. I never found the cause. And I’m still using for some blogging, and the bug still recurs. My solution: Just don’t preview the post.

I have little confidence that the theme is the cause of it. I’m just guessing here.

I got lots of hits on DDG for Wordpress preview 404. Maybe there’s something there you can use.

Except with WordPress, the links aren’t files on the disk - they’re entries in the database. 404 just means the CMS isn’t returning anything to you, for whatever reason that may be. If it weren’t I’d suggest that .htaccess could even be causing issues, or it could be something weird that has to do with a privacy extension installed in the offending browsers that’s messing with login cookies.

Does the preview link work if the post is published?
You said a second user on that machine has the same problem. Do you have a different Mac you can try?
And for a super-crazy idea, are you accessing the site via https in all these scenarios? A few weeks back my ISP apparently decided to cause problems with any non-https link that included a query string for “privacy protection”.
Are there any other “clean” browsers that you can try (i.e. what happens when you use a fresh install of Chrome?)

Just some weird thoughts. Hope you figure out what’s going on. :slight_smile:

Ok, this is probably very basic, but are you signed in as an editor on all those browsers? A preview link won’t work except for editors.

OK, now I’m thinking it’s not likely to be the theme that’s the problem. I encountered this bug again, in a blog using the Twenty Sixteen theme, one of Wordpress’s own.

In general, Wordpress has become a CMS rather than a blogging platform. It’s now lousy platform for blogging in the classic sense of the word, though it’s fine for the current definition of blogging. (Old man yelling at cloud.)