Calendar invitations don't appear in the Calendar Inbox - iCloud problem?

I’ve been having a problem that is so bizarre I can’t figure it out, and so far Apple support has been unable to figure it out. I recently made a big move from Google to Apple for email and calendar. But something doesn’t work right.

When someone uses Google Calendar to send a meeting invitation to my email address, the invitation does not appear in my Calendar’s Inbox. I do get an email invitation in my Mail Inbox, but not the Calendar Inbox. Because of this, I am not able to accept or decline the invitation correctly. This behavior happens with the Calendar app on macOS, iOS, iPadOS, and on So it doesn’t seem to be an individual device problem, but some global configuration. That’s why I assume it has something to do with iCloud.

I see the same thing regardless of whether the invitation is sent to my personal email (which is hosted by the same web hosting company that hosts my personal website) or to my email address.

Now the weird thing is that I can use Apple Calendar to invite someone on Google Calendar to an event, and when they accept the invitation, I do get notified that they accepted in the Calendar Inbox. So I know that Calendar Inbox is able to receive and process inbound calendar related messages. It just won’t do so with the initial meeting request.

Any suggestions or ideas?

(I spent about an hour and a half on the phone with two different Apple support techs about this. The first had me to all the obvious stuff, then escalated me to her “supervisor” who also couldn’t figure it out. He escalated the issue to “engineering” and said he’d get back to me in a day or two. That was two weeks ago.)


For starters on iOS Settings > Passwords and Accounts > Calendars when you look at Google/Gmail, Calendar should be off. Same for Mac equivalent (I’m not by my Mac right now, but it should be something like system prefs > Internet Accounts > Gmail).

Similarly, those equivalent settings should be on re iCloud.

Thanks for writing back. But I’m not even using Google Calendar. I have one iCloud calendar and one Exchange calendar (from my job).

Great… I was just suggesting that you make sure that only iCloud calendars were connected.

I cannot say whether or not your experience is expected because I keep turned off all calendar-based invites, in part because calendar spam was a problem a few years ago, so I rely on email invites. Anyway, good luck.

Hey @ToddBradley, did you ever figure this out? So frustrating and I am still having issues.

1 Like

I get the same behavior and it’s frustrating. Did you figure this out by chance?

1 Like

Same issue here, did somebody find the solution?

1 Like

Me too.

Anyone get a solution?

1 Like

I’ve spoken with Apple Support this morning - they we very good, but they haven’t come up with a solution yet?

Same issue here. Bumping this up to increase visibility.

Did anyone solve this problem? I can’t find the solution online. It’s insanely frustrating.

1 Like

I may have found a solution to this. If you go to > calendar > under actions go to preferences > advanced > change “receive invitations” from “in-app notification” to “email” and save. Yes, I know this has to do with receiving notifications, but after making this change, iCloud is also now sending invitations which GCal and Outlook can process as normal. I don’t fully understand what is going on here, but there seems to be an issue having to do with an Email address linked to an Apple ID when the iCloud address is not the primary Email or some such thing. This thread is what got me on the right path:

I hope others find this helpful, this is definitely way more complicated than it should be.