Can’t open ‘Office Open xml word processing document’ on iPad or iPhone


I keep getting a message on my iPad and iPhone that a document I’m trying to open is ‘Office Open xml word processing document’ but then doesn’t give me any options to open it.

Hers the scenario :
In my office we use windows pcs and when I need documents for a meeting I try to be paperless and have everything I need on my iPad, I attach documents to the event in my calendar (I use the built in calendar for iOS) and then open them from there as I need them. PDFs are never a problem, but Word documents are erratic; some open Ok and some just give me this error message.

I can’t find a solution to this anywhere, aside from putting my documents in a completely different app, which I am loathe to do as I need to keep them in my work’s Exchange system.

Is anyone else experiencing this, and has anyone found a solution?

Many thanks!

Did you also tried to save the Word documents in the second possible format („Classic“ docx)? Do you have Word app installed or which app do you use?

If you’re in a MS environment could you not store the documents in OneDrive and save a link to them in your calendar?
You should get 1TB of OneDrive storage if they’re using Office 365 as well as access to the iOS Office applications.

Thanks for your reply. I haven’t tried that but I could do. The problem is it’s an extra step in the process and when you’re dealing with multiple documents the time adds up. But thanks for the suggestion, I will think about it further. I have Word app installed on iOS and try to open them in that.

Yes, thanks for the suggestion, I am trying this but again it’s a bit of a pain to have to save documents in another location. We are using Office365 and it’s great to have the extra storage.

But I am still frustrated that some documents open OK and some don’t and there seems to be no answer as to why that happens and whether there is a fix for it.

Thanks for your help though!