Canon Canoscan 5600F driver not recognized (solved)


#1

Hi,

I try to install my scanner (a Canon Canoscan 5600F) on my MacBook Pro (Sierra 10.12.6).

I installed both drivers I found on Canon website (generic and TWAIN) compatible with this model and with OS X 10.12.

Scanner works correctly.

Then I tried to install the Canon scanning software MP Navigator EX 2.0.8 (from the same webpage) after checking for compatibility again. A restart was required.

When I try to launch MP Navigator, I just got an error message telling that the right driver recognized by this software is not installed.

I uninstalled everything (software and drivers) and reinstalled again, double checking for compatibility. Same issue…

Maybe anybody got the same problem and found a solution?

dw


#2

When you say the scanner works correctly, was this very old model (I think I bought one for my girlfriend in 2010 for $90!) previously scanning on this Mac, or a different computer?

Try downloading directly from this site, which is apparently different from the one you used since it does not also contain Canon’s Navigator software.

FYI I believe the previous driver (14.11.x) was 32-bit, and the 64-bit driver was part of the ICA series and had version numbers like 4.1.x


#3

It was working today on my MacBook Pro after installing the drivers, yes.

Here are the drivers references:
ICA driver 4.1.4a (compatible with Sierra, released Sept-20 2018)
Twain driver 14.11.5a (compatible with Sierra, released Nov-2 2018)
So numbers in the same series than you mentionned.

No clue in the doc about 32-bit or 64-bit.

I will check if your link provides other versions, and comment back thanks!

dw


#4

It’s unfortunately the same drivers…

I agree, it’s a fairly old scanner :slight_smile: (but it works quite well).

Probably not the right forum to ask but if you have an advise for a good make for a scanner compatible with Sierra and above, I’m interested to know. Via msging maybe to respect the forum rules. My main needs are importing pictures (either in archives or in Gimp) and create multiple pages pdf.

dw


#5

If you haven’t tried it, a restart couldn’t hurt.


#6

I did it twice (the first of them was mandatory to finish the installation of MP Navigator. You couldn’t escape the restart.
But it didn’t change the situation.


#7

Sorry to hear that. The one guideline I have had over the years for scanners has been: don’t trust the drivers!

The one major 3rd-party scan software / scanner-driver developer is https://www.hamrick.com/ with their VueScan software, which can be a little complicated and messy-looking but has been regularly updated and well-supported for around 20 years. The software lets you scan, scan to PDF, includes some type of OCR, de-skewers pages, and more. I know it mainly from the amateur photo world, where people used it to scan photos and negatives, where it saves to TIFF/RAW/JPEG, integrates with Photoshop, and supports infrared dust removal.

According to Hamrick it does support the 5600F:

That said, I have not used it. Years ago, when I used a desktop scanner for photography I used Lasersoft Imaging’s Silverfast driver, because it was simpler and cleaner-looking while remaining powerful. Isee on their page today that they too support the 5600F, but I don’t necessarily recommend the software in 2019 because I’ve read on photo forums that it isn’t being developed/supported as well nowadays…

VueScan is a free download with a free trial (and a 30-day money back guaranty), so I’d suggest you at leat try it to see if it helps. VueScan comes in two versions, $20 for scanning and a year of updates, or $60 to unlock film/slide scanning, OCR and color calibration.


#8

I tried VueScan and it’s not bad at all.

But looking elsewhere, I found exactly what I needed: Scanline. It’s a command line utility. It recognized directly my CanoScan. Scanline can be used to scan to pdf (even multi pages), jpeg and with different resolutions. Easy to use and free. I will use it for a while to see if it does anything I need.


#9

Great news. :+1:

The other suggestion I forgot to mention would be using an app uninstaller eg (iTrash, AppDelete, or the uninstaller module in CleanMyMac X) and dropping one of the installed Canon files on it and letting it search your System File innards to rip out all related installed files, then, once hopefully clean, trying to reinstall again from scratch. It sounds like the driver itself was okay but the subsequent installation of MP Navigator screwed things up.

For several years I’ve used AppDelete and it’s pulled all sorts of cruft when I delete an app that otherwise would have remained in my system. I also have CleanMyMac X but don’t use the uninstall module because AppDelete works so well. (That said, I read a 2016 or 2017 comparison review which found iTrash to be the best Mac uninstaller - and with the car crash death last year of AppDelete’s dev it’s the app I’ll probably switch to if AppDelete starts to falter.)


#10

I never used the uninstall feature of CleanMyMac before but just tried it and it’s really useful indeed. Thanks for the tip.

Just used it to get rid of anything related to Scansnap, my other scanner who just stop to work correctly recently, possibly after a Sierra minor update (I wrote a question about it a couple of days ago in this forum). Now that the old Scansnap version is cleaned with this smart uninstaller, I will try to reinstall.