Can't delete MacOS Installers

I have these two MacOS installers that must be made of titanium. I downloaded them to make some bootable usb’s and now the originals will just not delete! They keep throwing up notices about being in use or not having permission to delete them. I tried everything I found on the web, changed permissions, etc. but nothing so far works. Any ideas?

While you do not mention it, perhaps you’ve already tried rebooting?

When I’ve had similar situations where files would not delete because they “were in use” a reboot cleared the issue. Although it was not with macOS installers.

Thanks,yes I’ve rebooted.

In Terminal, this will print the process that has a file open:

lsof <pathname>

<pathname> might be something like ~/Downloads/SF-Symbols-2.1.dmg .

1 Like

Have you tried starting into Safe Mode, and delete it from there?
Have you tried disable SIP Mode?

Have you tried moving the installer to an other folder, and delete it from there?
Have you tried delete the installer from the Terminal?

I have this same issue on my work machine.

If you wish to fix, try the suggestions above.

1 Like

Hey, thanks everyone. As suggested, disabling SIP Mode worked, as described in the link with the duck.


Disabling SIP worked for me as well.

1 Like