Can't get Pandoc to work in Obsidian

I’m trying but I’m obviously missing something. I have installed the Pandoc plugin but I cannot find any command to export to Word or other formats other than HTML without Pandoc. I followed the instructions which advise against manual installation (which I’d be afraid of doing anyway given my limited technical skills).

I’ve installed and enabled Pandoc and restarted Obsidian but this is what I get when I try to invoke Pandoc export:

What am I doing wrong?

Okay. It looks like the pandoc plugin can’t find the pandoc command that you installed.

Reboot. This will be sure the PATH variable (the places the system looks for commands) is up to date.

Open Terminal and type this command and press Enter.
which pandoc
You’ll see something printed like /usr/local/bin/pandoc.
Use the mouse to select that text, then right-click and Copy.
In Obsidian open settings
Scroll down to the Pandoc Plugin settings and click.
Find where it says ‘Pandoc path’ and paste the text you copied into the field.
Close settings.
Close Obsidian.
Run Obsidian.
See if you have more choices for pandoc exports.

Thanks! You have no idea how nervous I am messing with Terminal–which I’ve never done! I had to Google how to involve terminal. It’s fine to laugh at me; I’m laughing at myself! :joy:

Before I do, is there any risk that I’ll screw things up and have to fix something?

So…I went to terminal and here is what I got:

Last login: Thu Dec 16 09:54:15 on ttys000

barrettmosbacker@Barretts-MacBook-Pro ~ % which pandoc

pandoc not found

barrettmosbacker@Barretts-MacBook-Pro ~ %

Download and install Pandoc from - then you will find it with which.

Provided the installation went well when you ran it, try this in the Pandoc Plugin settings in the Pandoc path field:


Close Settings
Close Obsidian
Run Obsidian
See if more Pandoc options appear in the command palette.

@JohnAtl @Rob_Polding Woo-hoo, it’s working thanks to both of you. I feel like such a geek. :joy:

Seriously, thank you!!

1 Like

I know this is a terribly overused cliché but this is a “game changer” for my use of Obsidian! I’m almost convinced that I can now use Obsidian to finish a book I’m working on. @JohnAtl @Rob_Polding thanks again, this is more helpful to me than you will ever know.


You’re welcome!
Congrats on the Terminal usage too!

1 Like