Can't Sync Macros on New M3 Max MacBook Pro

I’m setting up a new M3 Max MacBook Pro. I installed Keyboard Maestro. It loaded fine. When I select Preferences > Sync Macros > Open Existing …, I get a message that says, “This Will Replace All Your Macros.” I click on Replace All Macros, and then nothing happens. KM hangs with the spinning beachball. In a few minutes, it stops but without giving me the option to choose a sync file.

I tried reinstalling macOS, but that didn’t help. Also, every file dialog in KM seems to be affected, including all the file import and export options. I can’t use any of them.

How can I fix this? I’ve tried rebooting and uninstalling and reinstalling KM.

This is what I’m showing on my Activity Monitor:

I’m running KM 11.0.1 on macOS 14.1.1. on a brand new M3 Max MacBook Pro.

I recently installed Keyboard Maestro on my new MacBook Pro (M3 Max), and everything (including the sync) worked as expected. In my case, I keep the sync files in Dropbox.

If you haven’t already, I recommend sending a support email to the developer. While you’re waiting, you could also post on the Keyboard Maestro Forum.

I hope this helps!

1 Like

Terrific. I’ve done both. My sync file is in iCloud, but I can’t even get the dialog box to open. It’s encouraging to know it’s working for someone!

1 Like

Could the issue be iCloud not syncing and confusing Keyboard Maestro?

iCloud is synching. The file exists on my new computer. However, I can’t get KM to display an Open Dialogue box so I can pick it.

1 Like

Also, I tried re-booting into safe mode. That didn’t work either.

Okay, I fugured itr out—sort of. Apparently, there’s some kind of software conflict. I created a new user account, loaded KM first, and it worked fine. IfI had to guess, I think it’s likely a conflict with Google Drive. We’ll see.


After I set up a new user account, everything worked fine, even after installing Google Drive. I’m not exactly sure what happened, but I think the lesson for me is to install Keyboard Maestro first on a clean install.