CarPlay Headaches

I use Apple Car play everyday. But at least once a week, I plug in my phone and nothing happens, no Car Play at all. If I reboot the phone, then it usually comes back.

Do others have this problem? And any ideas how to keep Car Play working all the time?

I have an issue where if I plug my phone in before starting the engine then it’s 50/50 as to whether it will work or not.
That’s since 15.3, hard to remember to wait after years of muscle memory.

1 Like

I have a different issues and have intended to ask about it on this forum but never got around to it.

Location reminders is not activating in Car Play. It is working on my iPhone and Apple Watch but not in Car Play. Any ideas as to why? I have the latest iPhone and iOS.

@Bmosbacker : Some (all?) apps have a “Show in CarPlay” option for notifications. Look in Settings > Reminders > Notifications to make sure “Show in CarPlay” is still turned on. That said, I’m not sure how location-based reminders are supposed to behave with CarPlay, so this is just something to double-check and may not help at all!

1 Like

@margaretamartin Thanks for the tip. I checked it out and everything looks right but I deselected and reselected to see if that reset it properly. Thanks again!

Happens to me as well. I have connection via usb. Unplugging the phone and then plugin it in usually solves the problem. But not always. Sometimes I have to do it several times. Don‘t know if this problem is caused by phone or entertainment system of car

1 Like

General tips that have helped me with one vehicle or another:

  • Keep the lightning port clean
  • Try replacing the USB-Lightning cable
  • Check the USB port for secure connection (depends on model—one of ours was housed in cheap plastic in the armrest that was giving way too much)
  • Let your car system do system maintenance or a periodic reset (depends on unit)
  • Upgrade your car media firmware (depends on unit)
2 Likes

99% of the time this happens to me it’s the car, not my phone. I switch USB ports on the car side. Which probably means the connector shakes itself loose over time. If that doesn’t work, then I reboot the head unit (hold down the power button until it does of a full reset on my Subaru).

2 Likes

What happens to me is I’ll plug iPhone in and CarPlay will work fine and then 5 minutes later I’ll have to turn car off to, say, get gas. Then I turn car back on and CarPlay won’t fire up.

So now I check if I need to stop soon after departing and if so, I won’t connect phone until after restarting car

My guess is that the buggy-ness is caused by the entertainment systems in cars. My 2019 Toyota connection can only be fixed by turning off the car entirely. Rebooting the car, if you will. Super annoying, especially when it takes more than one restart.

I’ll go for months with no problems, then I’ll have a spate of problems, then it magically fixes itself. This is unrelated to updates of any kind (phone or car).

I’ve got clients who have given up on Car Play because it’s so unreliable, which is a shame. I did extensive troubleshooting with one client (Volkswagen), and wasn’t able to find a solution.

Swapping cables and ports is always a good test. But if it’s crappy car software or hardware, you’re wasting your time.

This happens to me, as well and it’s definitely my Subaru.

When restarting your car to troubleshoot you have to open the driver door, close the door, then open and close it again. Modern cars don’t fully “shut down” until the driver leaves the car, and even then it usually takes another 5-10 minutes for the car’s electronics to fully go into a deep sleep state. Doing the door tango simulates getting out if the car and back in.

Cars are hellashisly complicated distributed computers these days.

Hey there!! I used to have a similar problem, in that my CarPlay would randomly disconnect… I tried everything - resetting the car settings, “forgetting” the connection and reestablishing, trying a different USB-lightning cable, even reset my iPhone at one point and restored it. To no avail.

I went into my local Apple Store to ask about this issue and the guy says “do you have your phone on you?” I pulled it out of my jeans pocket and he immediately looked in the lightning port, got out a sim tray removal tool, stuck it in there, had a rummage round, and pulled out a hunk of pocket lint!

He said this happens all the time. Since then, I’ve never had a problems and it has been rock stable!

I hadn’t noticed this because I use a Qi charger on my bedside table to charge my phone overnight and really the only time I ever plugged it in was in the car!

So yeah - check the lightning port for compacted pocket fluff!!! Hope that helps! :smile:

2 Likes

No, I don’t have to open and close the doors to get Car Play working again. Just turning off the engine and restarting it seems to do the trick – thank goodness! But I’ll keep your advice in mind if it ever stops working.

When this has happened in my Volt, I’ve tried a million tips, and it seems to be about the USB cable. For some reason, CarPlay is way less tolerant of imperfections in Lightning cables. The lint in the lightning port has been a culprit, but mostly I’ve had to “retire” cables that charge perfectly well and transmit data between phone and computer just fine. New cable brings many months of “it just works”.