Catalina File Sharing - cannot check the box

I just upgraded the SSD and RAM in a late 2012 Mac mini. Did a clean internet recovery/OS install (Catalina - highest it supports). Was on High Sierra I think. I have had File Sharing set up for years, so I can access the Mac mini hard drive and also an external hard drive connected to it.

In trying to set things up on the freshly upgraded Mac mini, I find that it will not let me enable File Sharing in System Preferences>Sharing. The box is simply not clickable. A google (and MPU) search has turned up a couple ideas – namely unchecking and then re-checking, etc. But, I can’t even check it to begin with. It’s functionally (though not visually) “greyed out.”

I am stumped. Any troubleshooting suggestions?

Are you trying to share via AFP or SMB? If the former, that might be the problem.

This setting is found under the “Options…” button when File Sharing is highlighted.

I really should have responded before now - thanks for your reply! Yes, I found those settings. What’s weird is I just can’t check anything that sticks. When I try to check “FIle Sharing,” it will not check at all. When I go into options and check “SMB” it checks, but then when I back out and then go back in to confirm the selection, it’s blanked out again.

I can’t find anything online that even mentions it (all advice is to uncheck it and recheck it, or run a terminal command, which I have tried by the way). It must be something idiosyncratic and unique on my system, which I get that no one may be able to help me with… oh well.

Would love additional suggestions!

In other news, of course Airdrop and iCloud Drive are good workaround options to move stuff around Also, I have discovered deeper knowledge of Google Drive as a pretty great workaround that almost renders this native OS functionality unnecessary.

But it does bug me that I can’t get the native functionality to work, because it does affect certain things still…

It’s very strange! I find an un-clickable checkbox very disconcerting, especially when it deals with the filesystem. What’s even stranger is the fact that you just did a clean installation, because this sounds like a problem somewhere in the operating system. It’s hard to know if it’s a minor problem or not (that is, will this problem only affect file sharing, or is something more damaging going on?).

In case you didn’t come across this Security/Privacy suggestion in System Preferences:

The process smbd is related to SMB file transfers, and thus file sharing. It’s worth taking a look at, though if smbd doesn’t appear in full disk access, I have no idea how to add it! But if it is there and turned on, I’d try toggling it off, waiting for the process to stop, and then reenabling it.

Another thing — did you use Migration Assistant to move data to this Mac after it was updated? If so, that could have brought a damaged file or could have damaged something in the process. (Note: it shouldn’t have, but clearly something went wrong.)

You could create a new user and see if you can enable file sharing for that user. That should tell you if the problem is at the operating system level or if it’s unique to the account.

If all accounts are affected, you could try reinstalling the operating system. I’m pretty sure you can just reinstall right on top of the current installation without removing your data. I’d try that, first.

If that doesn’t fix it, then I’d wipe the disk and reinstall the operating system. Then bring your data over without using Migration assistant.

If the new account is not affected by this bug, then I’d move my data to the new account. Don’t use Migration Assistant, just in case. Instead, just move the data and reinstall apps. You won’t easily be able to copy data from one account to another — its much easier and more reliable to copy the data to an external drive from the original account, and then from the external drive to the new account. (Doing so avoids problems with permissions, as permissions are not (usually) enforced on external drives.)

Thank you so much. I will try these steps when I have time and see how it goes!

Did you find a solution to this? I’m also on Catalina, have the same problem (FileSharing checkbox is not clickable). Initially I thought my OS is cluttered, so I re-downloaded it and re-installed everything. Did not use Migration assistant. Fresh install - box is still not clickable. Very frustrating.

No I never did. Just have given up for now. I agree it’s frustrating! I would certainly be delighted if you find a solution.

I’ve been struggling with this problem for two days. I couldn’t check the “File sharing” box either. Then I just started the smbd process with the command in the terminal

sudo launchctl load -w /System/Library/LaunchDaemons/

After that it became possible to check the box “File sharing”. I restarted the computer, Shared access remained active and now everything is working. Hope this helps.
I took the information here:

Just tried this. Got “No such file or directory.” What is my next step?

Never mind - found this Trying to Add smbd back to Full Disk Acce… - Apple Community

And then your fix, and voila!! Thank you!

1 Like