Catalina Will Not Delete!

Hi all.

I created a boot stick for Catalina and once I had finished with it, moved it to the trash.

I now cannot delete it completely due to the following:

When I stop the application it still will not delete. It is sitting in my trash as there following:

Screenshot 2021-05-07 at 10.43.38

Any suggestions?

Many thanks,


So, to be sure: you have a USB boot stick for Catalina and you want to delete the contents sitting on it?

The easiest thing to do would have been to format it using disk utility. How? Like that:

That might not be an option now depending on the state of this stalled deletion attempt, so you might try something more rude:

If this works out, you probably may want to format the USB device after that following the instructions in the MacWorld article above.

1 Like

Hi Christian.

I have already cleared the thumb drive with disk utility. This is a file that is sat in my trash on my Mac.

Running Big Sur



Have you tried starting Activity Monitor, and looking for
a stray process? (Usually the naming is obvious)

I have exactly the same problem. April 18th I was making some bootable thumb drives and one of them got stuck just like you describe. I was only able to get as far as deleting the icon. File now shows a file named contents. Inside is another folder shared support. Inside that is the installesd.dmg image.
Have don full reboot. Tried to remove using Terminal. No luck.
I had not thought of this platform for help. So glad you did.

1 Like

Try the steps at

1 Like

Skynet will take precautions to protect itself.


Move “Install macOS Catalina” from the Trash to the folder /tmp/.

Reboot your Mac.

/tmp/ is cleared out on reboot, so that should get rid of it.

That did it. Thank you so much @Christian
That was a winner.