Cisco AnyConnect Secure Mobility Client

My university uses Cisco AnyConnect for VPN connection when off campus. Last week, it stopped working for me. I have uninstalled, reinstalled, etc. but it won’t even make contact with the server (been through levels of tech support). The last resort is a nuke and pave and I can’t bear the thought of that when everything else is working well. Any ideas?

Do they provide the settings? We also have a Cisco VPN, but I just put the settings directly into the Settings > VPN area and it works like a charm.

Thanks for the reply. They provide the settings. It’s configured correctly because I get an alert in Duo Mobile (our 2FA system). It connects from the ipad, not the laptop.

I have done it in system preferences on the Mac too, in the Network settings and it works no problem. If they have a Radius log you could ask them to check that to see what error you’re encountering.

Have you tried creating a new user account and testing from there?

Another option, although I have not tried it on macOS, would be to try using openconnect. It is an open source package that works with AnyConnect SSL VPN. I was able to use it on Linux a while back when the software package wouldn’t install correctly in a virtual machine.

You said above that it doesn’t connect to the server, but in this post you said you get an alert on Duo.
Could this be a Duo problem?

Thanks. Just tried in system preferences. No go. They can’t see any evidence of me trying to connect on their side.

so you are connecting from the laptop? At my university we have to go to vpn.<institution_name>.edu and log in there first, and that downloads a special flavor of the Any Connect app. Does your school do anything similar?


I’m not a Cisco user, but I’ve done a fair few years of support, including VPN access, so…

  1. What steps are you taking before encountering the error?
  2. Most importantly, what error do you get? One on screen? Anything in the Cisco application’s log? It’s ike forensics … there’s always a trace of what’s going on somewhere.
  3. This stopped working but was working previously. What changed on you device in that time? Any new software, anti-virus update, uninstalled something you don’t use any more?
  4. What have your IT staff said they are going to do next? It isn’t normal to just be left hanging … presumably they have a plan (did they suggest rebuilding your machine?) and you’re looking to increase the odds of a speedier resolution by asking for help here.
  • Since it works on another device and presumably other colleagues have no issues from similar devices it points to being a local issue.
  • Given you have not mentioned issues with anything else, it does not sound like it will be a connectivity or hardware issue.
  • You have reinstalled (presumably reconfigured according to your organisations latest instructions), so it shouldn’t be an issue with your software.
  • That leaves software that there’s some overlap or interaction with. Maybe some network restriction has been enabled on the OS or security software you may be running for example.

The more detail you can provide the more chance someone will have of spotting a familiar symptom or root cause that can be advised upon.

All good info. I’m meeting with our very capable IT person in the am to explore further.

It turns out to have been caused by (recent upgrade) of Little Snitch. It was blocking the connection to the computer. We uninstalled (for now), uninstalled AnyConnect-reinstalled—then restarted. Worked just fine afterward.

I’m not sure I really need Little Snitch–just drank the Katie-David MPU Kool-Aid :slight_smile:

good to here it worked .

cisco anyconnect is a horrible software poorly maintained by cisco .

as mentioned before OpenConnect do work perfectly .

i dont use anyconnect since sierra anymore .

you can use homebrew to install - brew install openconnect ,