Clamshell chaos

hi MPU gang
Been having intermittent clamshell issues – running M1 Max MBP with Studio Display. If I unplug and use the MBP as a laptop and then plug back in to the Studio Display the display lights up and I can scroll across to that ‘extended desktop’ (with MBP still open). But as soon as I clamshell I get nothing and have to fully reboot the MBP.
I’m at a loss as to how best to start troubleshooting but it drives me bananas (such that I’ve taken to bringing my M2 MBA into work to save unplugging and rebooting! Not a great solution. Oh, this only started happening recently but not sure if coincided with update in MacOS.
Any support, advice, similar tales of woe, empathy, donations very welcome.
Cheers all

Do you have any external hard discs attached to anything in the setup? If so, have you tried physically detaching them before you connect to the studio display?

I used to have similar issues with clamshelling an M1 MacBook Pro, but mostly resolved them by disconnecting an external SSD before connecting the Mac (I had read of similar problems elsewhere)

1 Like

Have you tried the other way around? Arrive at desk with closed Macbook (keep it closed) and just plug in the Studio Display. That is how I do it with my LG Ultrafine 5K display and it works every time.

thanks @Dewald – I have indeed. (that’s my usual way).

cheers @shandy - I seem to remember reading something about having external drives attached screwing up clamshell mode. I do have a timemachine backup. Will do some proper ‘tests’ to see if that helps at all. Thanks.

Yes, I think this seems to fix it. At least it did the first time. Anything else comes to light I’ll share. But wow it does seem crazy that it doesn’t “just work” even if I have an external hard drive attached. Cheers all. Simon

1 Like