Command tab suddenly stopped working

The default application switcher (CMD + Tab) suddenly stopped working Any suggestions?

Try logging out and back in again, or killing the Dock process.

Thank you @jec0047, I can’t tell you how much of a life saver you are. The terminal Killall command didn’t work but logging out did.

I take it back, it only worked for a little while and then stopped working again.

An alternative to killall that might work is opening Activity Monitor, selecting Dock, clicking the ‘x’ button in the title bar, and choosing Force Quit from the drop-down modal box.

SOLVED: Stupid user error. I gave a Keyboard Maestro macro the shortcut command + tab and forgot about it. I almost restored my Mac.

I did uninstall Chrome which made the shortcut fail and I figured out what the problem was.

Free Advertising for Homebrew and Cask: This problem allowed me to uninstall Chrome and reinstall it through - Homebrew and Cask - doing things via the terminal is always cleaner.

3 Likes

There was this one time I couldn’t click anything. Clicking just didn’t work, and no fix or reboot would solve it.

After half an hour, I learned that I’d left a mouse or trackpad on in my bag, pressed against something in a permanent click.

(Best part: it only took me ten minutes to figure out what the problem was the next time…)

3 Likes

I know this feeling!

For weeks, my wife’s iPhone was acting very strangely - several year’s back.
When typing, her iOS system keyboard would randomly disappear/reappear, for no apparent reason.
I eventually narrowed its behaviour pattern down to it only occurring in the kitchen.
And then eventually worked out that it was successfully pairing/unpairing with a multi-device keyboard upstairs in the study, that I used on my MBP.
At some point, I had paired it with her phone in trying something, and completely forgot about it. When she was in the kitchen, she would most frequently be messaging - and that was when it was close enough in range to try and pair. Everywhere else, it couldn’t, or she wasn’t trying to type.

Never occurred to us to check for BT devices - all we had to work on was a randomly disappearing keyboard.

Glad we managed to resolve it - but was driving up both nuts >> “I thought you said Apple devices ‘just work’?”

2 Likes

That’s hilarious; nice job figuring it out.

2 Likes

Ditto - for me it was a Magic Mouse in a nearby closet!

2 Likes

How about when you’re in bed reading on your iPad, then everything goes wonky, instead of scrolling you’re zooming, etc. Then you realize your belly is touching the bottom of the screen.

2 Likes