Compass on iPad/iPhone/Watch significantly off after January system updates?

Is anybody else seeing the Compass apps (and the compass function in Maps) have major errors following the system updates from earlier this week?

For me, everything across watch/phone/ipad seems to be rotated about 60º to the right of where I’m actually pointed. I’ve tried restarting, turning location services off and on, compass calibration off and on, even deleting and reinstalling the Compass app. But the errors persist. Given that the phone and iPad use entirely separate systems but are off in the same way, I’m wondering if this is some sort of bug in the latest releases, or some sort of services-related error.

Anybody else?

Interesting, the Compass App on my Xs is working correct.
But I do not have this App on the iPadPro, nor on my Series4 Watch.
And while it seems, that the App is in general not Available (anymore?) for the iPad, I also see no way to get it downloaded to the Watch.

The Function within the Maps Apps on all devices are running without any problems, or misleading.

If you have a look into the App-Store Feedbacks to the Compass App, there are a lot of complains about the App not pointing into the right direction, also from a year ago and later. So it seems to be a common problem, without a connection to the last update.

did you try the true north, vs magnetic north switch?

although that’s a lot of declination.

For a declination of 60°, he has to be somewhere south of Australia, short of Antarctica… :thinking:

No, it’s not the magnetic north setting. (I’ve tried toggling that off and on).

And as I write this, the phone seems to have mostly corrected itself (still off by maybe 15º) while the watch is now close to 180º off.

Wow I tried it on my Apple Watch, and iPhone 13 - yes they are about 60 degrees off from each other. Crazy!

I turned off and on “use true north” on my phone, and that didn’t change much - my declination is about 12 degrees.

Although it doesn’t take much to convince me of a software bug, it could also be a coincidence with the update cycle. Unless, of course, you noticed it immediately before and after the update.

I bought a GPS unit for my camera and the instructions do say to stand away from metal structures when calibrating it (something it says to do any time it is turned on in a different location, or when the battery is changed).

I took all that with a grain of salt until I discovered that I really do have to be well away from structures for it to successfully calibrate… like 10-20 metres away.

Maybe something in your environment changed, or was changed at the time you rebooted the phone as part of the update. I don’t know if there might be some basic calibration steps done on startup from cold. A manual recalibration still not curing it would suggest a permanent change in your environment.

I am reminded of a story my sister told me of a friend who was an electronics technician, whose very large and fancy TV (this was in the 80s) developed a colour shift in one corner. Short version… After much tinkering in back of TV and attempts at degaussing… “Honey, what’s that new ornament on top of the TV?” “Oh, it’s a cool magnetic thing…”

1 Like

Yes, it always gives me a big Grin, if I observe people (often military) placing their maps and compasses on top of the hood of their cars, to do their route planing…


A wee bit off …

Looks like I’m off by 20 degrees sitting on my sofa this afternoon

But, if I have a look onto the two “analogue” ones on the photo, I wouldn’t trust any of those three compasses.
So I would have a look for a metal construction in the vicinity (20m) of them, before I would compare them.
I made almost a bet, that the table has a metal base…

Yeah, no. How much are you willing to wager? You lose. There is no metal base. No metal causing any issue.

One is a good compass. The other a toy. Both are clearly pointing north.

I’d trust either.

The iPhone is clearly off. Complaining about a slight discrepancy between the two single use devices misses the forest for the trees.

There is clearly a problem with the iPhone.

My iPhone is accurate to the degree, so it seems to be not a general problem.

Maybe one of this „tricks“ could solve the problems