Connect to my Mac Mini from my MacBook

I want to connect my MacBook to my Mac Mini both recently upgraded to Catalina.

I’ve done it before - in particular I use it as a way of backing up (Time Machine) to an external hard drive attached to my mac mini, never been a problem. It should be simple but now it’s not doing as it used to. It looks like it’s connected, it says it’s connected in System Preferences/Sharing but when I try and go in I can’t see beyond the ikon of a shared folder. It does not show any other folders or the eject symbol that usually shows when you are connecting to another computer.

The Mac Mini can connect to the Mac Book ie it’s ok the other way round.

And I have another old MacBook Pro (on an older OS) that can connect to the Mac Mini

But the Mac Book won’t connect to the Mac Mini.

I have checked they are on the same wifi network

Any thoughts?


It’s definitely doable, I use mine in the same way. Maybe check the sharing settings to ensure both systems allow access from the same account etc. Under remote management?

I’ve checked the sharing settings and I can’t see what else I can do. There is only me that uses these computers. I’m not sure what else to change. If I disconnect and get the “Connect as” button. I click it but don’t get any options.

I think from memory mine is set up under remote management with log in via Apple ID. I’ll check when I’m back in. Outside of that maybe a vnc app?

It looks like the OP is trying to access a remote shared folder, not the remote screen (i.e. VNC).

On the target machine (the machine hosting the share), under System Preferences -> Security & Privacy, does “smbd” have either full disk access or at least access to the top level folder you want to share?

On my MBP, it is listed under “Files and Folders” but might be under “Full Disk Access”.

You may want to look at the Users & Groups panel in System Preferences, too. These settings affect network file sharing in various ways.

For example, I had a client who couldn’t get public file sharing to work after following Apple’s instructions. This should be the simplest thing to do — but it turns out that you also must turn on Guest users in order for this to work. On one hand this seems non-sensical; why do I have to allow guests to log into my computer in order to allow sharing of the Public folder and the one-way Apple Drop Box? On the other hand, if you know about Unix and permissions, it makes sense that they’re related.

So, depending on how you are trying to connect to the Mini, it’s possible that you need to allow a different type of login access. And with Catalina’s increased security, this could be why your Catalina Mac can’t reach the Mini, but non-Catina Macs can.

1 Like

Many thanks Joe. There is no smbd here on the MacMini (the target) in either place. Where do I find it to add it?

That’s done it Margaret! Many thanks. I knew it had to be something simple! I really appreciate your taking the time to respond to my query. Very best regards, Stephen

I’ve sorted it Ethan. Margaret (below) told me I had to have the Guest user active. Who would have thought that! Anyway many thanks for taking the time to respond to my question. Very best to you.

Perfect! Would never have guessed that!

Just FYI as it looks like things are fixed.

It’s located at /user/sbin/smbd.

Yes thanks Joe, it is fixed. But good to know where to find smbd for the future. I really appreciate you taking the time to respond to my question. Very best, Stephen