Cryptic error when running iOS apps on M1

So I haven’t really had much of an urge to install iOS apps on my M1 MBP since I got it almost a year ago. Today I wanted to listen to a podcast on my MBP so I downloaded Overcast (which is what I use on iOS) since presumably the M1 should be able to run the iOS app alright.

However, when clicking on the app, there is no response (no bounce in dock, no window). I tried to run it from the terminal and got this cryptic error, which I can’t find anything about from a quick Google search:

$ open -a Overcast
_LSOpenURLsWithCompletionHandler() failed for the application /Applications/ with error -10671.

Has anybody here encountered this issue before?

This probably does not help much, but Overcast has been working fine for me on the M1 MBP (and the current version is running fine). Have you tried installing and running any other iOS apps?

Sounds like a permission issue.

Close… after some more research, I figured I should probably check SIP settings:

Changing “Startup Security Policy” from “Permissive” to “Reduced” fixed the issue.


Thanks so much for this solution! I’m now able to run iOS apps on my M1 MBP.

1 Like

Thanks, @ThatNerd and @jcarucci!
This is impacting me too. Strangely, normal google wasn’t showing any useful results
When I searched for
_LSOpenURLsWithCompletionHandler() “failed with error -10671”
I switched to images and a link to this thread came up. So odd.
This and the SE thread should have popped up!
Seems like a lot of search results having to do with running iOS apps on M1 are suppressed.

I’m having the same exact issue on my MBP M1 with the error -10671. However the change from Full to Reduced did not fix my issue. I’m on Ventura 13.4.1. Same issue for 3 different iOS apps which used to run flawlessly. I know they ran ok on Monterey. I hadn’t used the iOS apps for a while and noticed they stopped working for me about the 2nd update of Ventura but can’t say for sure precisely when they stopped working.

“csrutil status” command from the terminal interface shows SIP enabled, which I believe the default for Ventura, and I also believe from the posts of others that it has to be enabled for the newer versions of MacOS.

Do you recall what level of MacOS you were on when you got the iOS apps running again?

Apple keeps locking down security with every update. You have to read between the lines on these issues and it is really hard to get any clarity on those updates they make.

Thanks in advance for any insight you might have on this!