“custom access”

Presentation today, need to copy to a usb drive. What fails? Finder.

I can’t use any of my usb thumb drives.
Permissions says “custom access”
Reformatted with Disk Utility- same thing.

Any ideas?

Does attempting the copy in Terminal give the same error?

Doesn’t feel to be Finder per se, but a lower level issue that is reflected in Finder. Are you sure this USB drive actually works?

Howard might have an answer

CleanMyMac (and others) have a tool to fix permissions errors. It’s probably for this kind of thing, though I have no personal experience.

Thanks all.

You’re probably right, @mina .

I tried five drives, three brand new. Tried formatting a couple with Disk Utility.

I even added Finder to full disk access.

I’ll look up the article @quorm posted and deleted for more info.

Luckily ResilioSync saved the day, and synced files to my laptop.

I will need to figure it out soon though.

Is there perhaps a permission issue with the source document(s) and not the USB?

Did you try garlic tied on your head at high noon along with downing a stiff shot of Johnnie Walker Blue Label? (Apple has rarefied tastes, as we know.)

1 Like

No, I’m using Get Info, and it says “custom access” which apparently means “no access”.

I’l check the unix permissions when I get home. Still, reformatting should have taken care of that. I also ran Clean My Mac’s repair permissions - not that I’m a believer, but was just something to try.

In my experience “custom access” means the file has some extended attributes attached to it, probably a macl (mandatory access control) attribute. You can view and clear these with the terminal command xattr.

Thanks.
I’m using Get Info on the usb drives. They are the things with “custom access.”

How are the USB drives formatted?

Directories can have extended attributes too.

First try “ls -ld /Volumes/Your_USB_Drive”. If you see something like

drwxr-xr-x@ 1 root wheel 1 Sep 27 10:26 /Volumes/Your_USB_Drive

(note the “@” sign at the end of the file mode) then the directory has extended attributes, which you can then print with “xattr -p /Volumes/Your_USB_Drive”.

FAT32

Well, it’s working now. :man_shrugging:

I had already rebooted before I left today. I uninstalled MacFuse before rebooting. Nothing helped.

Now, the USB thumb drives still say “custom access”.
Looking at the extended attributes, they are the same as when they wouldn’t work.

(base) Johns-iMac-Pro :: ~ » ls -led@ /Volumes/FAT32
drwxrwxrwx@ 1 john  staff  16384 Oct 13 17:24 /Volumes/FAT32
	com.apple.filesystems.msdosfs.volume_id	    4
(base) Johns-iMac-Pro :: ~ » xattr -l /Volumes/FAT32
com.apple.filesystems.msdosfs.volume_id:
00000000  FE 10 BC 89                                      |....|
00000004

As best I can tell, the permissions on the ‘real’ drives hasn’t changed either, and is the same as other drives in /dev.

(base) Johns-iMac-Pro :: ~ » ls -led@ /dev/disk15*
brw-r-----  1 root  operator    1,  45 Oct 13 17:34 /dev/disk15
brw-r-----  1 root  operator    1,  46 Oct 13 17:34 /dev/disk15s1

I reformatted one of the thumb drives as APFS and it allowed me to copy to it. I formatted as FAT32 again, and it still allows me to write to it.

I must have set off the Critical Need detector that is common in electronic devices, and that causes failures when you really need them.

You’ve evidently fixed this by other means, but my next suggestion would have been to try ExFAT instead.