Desktop not responding and not displaying drives/files

Running High Sierra 10.13.6 on a 2017 MBPr. Yesterday my desktop stopped displaying drives and files, and right-clicking on the desktop does not bring up the context menu. I think the problem started when I woke the system from sleep (I normally turn it off, but that recent thread about sleep vs. restart got me to try it. Oops.)

The settings for displaying drives on the desktop are all turned on. I’ve tried force quitting Finder even though it was not listed as not responding in the force quit dialog. I’ve also tried rebooting the Mac a couple of times. No luck. Does anyone have any other ideas for troubleshooting? I’ve come up empty on DDG and Google. The hits are for articles on force quitting non responsive apps, which I’ve already done.

Have you tried booting in safe mode yet?

It sounds like the desktop has been disabled somehow.
There are a couple of terminal commands in this post, one to disable the desktop, and one to enable. You could try the enable command.
N.b. I haven’t tried this.

defaults write CreateDesktop true
killall Finder
1 Like

Boom. That worked. Thank you.

That is extremely interesting.

I wonder what caused the Finder to NOT be set to create the desktop in the first place?

No idea. That is definitely not something I did intentionally (or unintentionally as far as I know).