DEVONthink Edit Question iOS

You have been a world of help, thanks! You solved one of my few pain points with DT. All of my databases in DT show up in the Files app and I can access the same databases from PDF Expert. I owe you one! :slight_smile: image

1 Like

Glad I could be of help. Just paying it forward.

1 Like

I don’t have a yellowish iCloud Drive icon. Here is what my copy of PDF Expert looks like. I even upgraded my PDF Expert for $10 so I could edit documents in case that was the problem, but it didn’t fix it.image

On the iPhone it is yellow ish. On the iPad it is different. Click on the pic of the cloud with the word iCloud Drive next to it. Once you do that you are in the file dialog. Keep clicking in the upper left to go back until you see the Locations. Once at locations you can see all your file providers. Click edit if you don’t see DEVONThink.

Wow! It worked! Thank you so much for your patience with me until I got that figured out. I was able to highlight a pdf and those highlights were visible in DEVONthink. Awesome. My new problem is PDF Expert is acting very weird. I can’t seem to delete highlights and it was even hanging and not letting me re-open files. But that is a different problem. I hope DEVONthink fixes their annotation so we don’t have to do these work-arounds, but in the meantime, I’m very grateful to know this.

Now— is there any way to get my DEVON folder to stay in the sidebar of PDF Expert? That’s a lot of clicking over and over. I’ve added my DEVONthink folder to my favorites, but still I don’t see a way to get it to show up in the sidebar. There is a lot of real estate on the sidebar I would like to take advantage of.

Over on this thread @Scottisloud recommended PDF Viewer. That seems to be a quick and dirty way to do the same thing. I can open my DEVONthink PDFs in place without copying them, mark them up and those markups are visible within DEVONthink. I was running into sluggish performance on PDF expert and this is a nice alternative. Thanks Scott!

1 Like

These two discussions on DTTG and PDF annotating have been very helpful.

The issue I have now is that I can access/download the documents within DTTG, but not through the iOS 11 files app/document picker. All the documents are greyed out in the files app.

Is that because the files need to be downloaded to my iPad prior to accessing them in the files app? My current setting in DTTG is to download the files “On Demand” rather than “Always”.

I’m using a Webdav file location. Not sure if that’s relevant or not.

Thanks, everyone!

That is strange behaviour, and not something I had noticed until you mentioned it.

I tried to recreate it by doing what you did on my iPhone, and could then see the issue.
But simply rotating the device into landscape mode, left ample ‘space’ to the left and right of the content, meaning that the option to move the toolbar left or right, solved the problem.

Have you tried that? Will give it a go on my iPad when I have a moment as well, but thinking it would do the same.

That might be the issue.

I have found to be a bit unstable, and needing to reload it a few times, and wait, before waiting to properly access my DTTG2 files.

That said, whereas most of my data is available on device, I too see items ‘not downloaded’ as being ‘greyed-out’. I guess that would make sense, since the file is not ‘in’ DTTG2, so to speak?

1 Like

Yes. This has been a very helpful thread! Thank you to all! What started this thread was my text annotation tools were on top of my pdf and I couldn’t read the pdf. I discovered something interesting. After I downloaded PDF Viewer, the problem with DEVONthink to go’s annotation toolbar seems to have gone away! I can now resize the text so it gets out of the way of the toolbar. I don’t know if downloading PDF Viewer was the fix (that doesn’t seem possible), but they do use the same editing engine and my problem seems to have gone away. Weird. But cool.

1 Like

Glad you are liking PDF Viewer! I was a bit late to the party because I was so committed to PDF Expert, but once I switched my PDF library to DEVONthink (and iCloud Drive) I found PDF Expert to be a bit cumbersome. PDF Viewer gets you to your files with minimal friction. PDF Expert requires a boatload of tapping, so I really only use it from time to time these days if there’s something it does or does more easily compared to PDF Viewer (though honestly there are few features in PDF Expert that PDF Viewer doesn’t also do!)

1 Like

I tried rotating the iPad and it didn’t help. I don’t have devonthink installed on my iPhone yet.

One item that is a show stopper for me with PDF Viewer and DTTG’s editing capabilities is the Saved Stamps.

When you create a saved stamp with a date/time signature in PDF Viewer or DTTG, it saves the time the stamp was saved not the time you create the stamp in your document. I use stamps such as Revise, Revisit, Stopped Here and want the time I put the stamp in the document to be the date/time the stamp has.

PDF Expert uses the date/time the stamp is added to the document.

Also, I prefer to have the same editing capabilities on my Mac and my iOS device. PDF Expert gives a similar experience on both.

DEVONThink 's PDF editing capabilities/user friendliness on OSX seems to be very different than the one built into DTTG. I find it hard to work with on OSX, can’t change the color of the underline, etc… I haven’t seen PDF Viewer on OSX.

Just sharing what works for me. Sometimes it is those edge or corner cases that drive our selections.

1 Like

This looks intriguing - but I am missing where the “stamps” feature is triggered?

Or maybe we are talking about the same thing, since I don’t know what to call it - on the Annotation toolbar, are you referring to the [Note??] icon, that (kind-of) inserts the digital equivalent of a sticky-note onto the document?

Here is info about creating the custom stamp: Working with Stamps

It looks similar on both the iPad and the iPhone.

Ah - I misunderstood your initial post, thought this was available in DTTG2/PDF Viewer.
I have PDF Expert on macOS and iOS – have have a look. Thanks.

DTTG@/PDF Viewer both have this, but when you create a custom stamp, the date/time stored with that stamp is the time you saved the stamp.

When you insert the custom stamp into your document, the date/time is still the date/time the stamp was initially saved as a custom stamp not the date/time that you inserted it into your document.

I don’t understand why anyone would want the time the stamp was initially created as the time and not the time the stamp is inserted in to the document.

I sent a future request into PDF Viewer many months ago. Hopefully it gets updated in the future.

I finally heard back from DevonThink on this issue. A week to reply is not very impressive. The message simply said, "Thank you for your feedback. Currently the PDF toolbar (and a similar one for sheets) can only be placed left or right of the document. Wouldn’t it be a solution to make it possible to make the PDF display a tad smaller so that it leaves room left or right for the toolbar?

Eric Böhnisch-Volkmann, President "

I explained that I could not make the pdf any smaller (only larger). Anyway, as I mentioned above, installing PDF Viewer fixed this issue for me, but I thought I would update you what DevonThink said (and how long they took to say it!). If there is any more feedback, I’ll update here. Thanks again to everyone on here that helped solve my problem quickly!!!

Devonthink wrote back and said: “The PDFs are all created from web pages that have no margin. I’ll open a development ticket for this issue.” I haven’t heard anything more.

Me too. Thank you. So very helpful.