Disable headphones nearby distraction/message?

My laptop and iMac Pro are alternating telling me my AirPods Max are nearby. That makes sense, since they’re on my head and I’m using them with my iPhone, which is also nearby.

Is there a way to disable this distraction/message?

Remove the AirPods from Find My.

Odd, my airpods are in findmy, all notifications on. I never get these annoying prompts…

1 Like

There’s a setting on the Bluetooth menu (both iOS and MacOS) which allows you stop the AirPods connecting automatically to any of your devices.

When the AirPods are connected, click on their Options in the Bluetooth menu and change ‘Connect to this Mac’ from Automatically to When last connected to this Mac.

You’ll have to do this on both devices (and on any iOS devices as well, of course – the process is the same… Just connect them and click on the Information “circle i”, then Connect to this iPhone’ etc. It does mean you’ll have to choose the connect the AirPods explicitly with each device, but that’s no hardship.

It used to annoy me a lot till I found this – ‘Automatically’ is a daft default to have chosen, because the effects are unpredictable.

Does that help?


It did, thanks!

1 Like

Hexed myself. Just started getting notifications that my MB Air is not with me. So now I can never leave it home without it developing separation anxiety? :frowning: