Disk Not Ejected Properly - multiple times a day

I have an SSD connected to my MBP via an OWC dock. When I wake the MBP from sleep I have half a dozen identical notifications “Disk Not Ejected Properly - Eject before disconnecting or turning it off.”
Any suggestions?

Same for me. Happens intermittently on both my iMac Pro and by MacBook Pro.
Folks are saying it has to do with USB3, and that some Windows users have the same experience.
I haven’t tried it, but the Jettison utility might help.

Also look at your energy settings. Make sure the machine does not try to put the ssd to sleep

1 Like

I just checked my MBP, and sure enough, try to put hard disks to sleep was checked. Maybe that will help.

Having said that, I find usb 3 to be wonky on macOS sometimes requiring multiple disconnect-reconnect, powering hubs down and up, etc. to get macOS to realize a disc has been connected.

I’ve got a couple of USB 3.1 drives connected directly and haven’t seen this. May be the hub/dock doing funny things.

I haven’t seen that yet – I add / remove quite a few USB 3.1 SSD drives on my MBPro. I wonder if there’s a difference between SSD and non-SSD handling. I don’t know why there would be, but, just saying …

It’s definitely an issue on spinning drives. It seems like it may have been on SSD also.
When I connect my hub with spinning drive, Ethernet, keyboard, and mouse adapter, everything except the drive works. Waiting for laptop to fully wake up, I can disconnect and reconnect and it works.

Similar paradigm at home, except with a more expensive powered hub that I hoped would resolve the issue. It did not.
Since getting my iMac Pro, I don’t use that setup at home anymore, so that issue is resolved :slightly_smiling_face:


Another thing I’ve noticed is that the USB 3 connectors on my MacBook Pro are not all equally effective in securely setting the connection. Don’t know how to describe it other than some of the four ports are “looser” than others. The male and female hardware for USB 3 is definitely not as good as staying connected as the other USB modes.

I should add I have a 2015 rMBP.
Was a bit confused when you said “four ports.”

Jettison just did its job and mounted my spinning drive at school, so maybe it’s a good workaround.

Oops, sorry. MBPro 15" 2017 – has the four USB C ports.

1 Like

If external drives, SSDs or spinning HDDs, are connected by USB3 cables, you might try troubleshooting the cables. USB3 cables for external disk drives are notoriously cheap and flimsy. I had the problem with multiple “Drive Not Ejected Properly” notifications a while back. The problem was resolved immediately with a new USB3 cable sent by tech support from the HDD manufacturer.

I later bought a replacement USB3 cable from Amazon, just to have a replacement on hand “just in case”. It is much thicker than the original USB3 cable that came with the external USB3 HDD. If that’s what it takes to make the drive reliable, I’m OK with the thicker cable.

1 Like

When my computer goes to sleep, I don’t get the HDD/SSD “improperly ejected” message even though I’ve got an SSD attached to my mid-2012 iMac via Thunderbolt 1. I’ve also had no problems with up to 6 HDDs attached to a USB 3 hub, which itself runs through a Thunderbolt to USB 3 adapter, in other words, plenty of opportunity for issues.

I do get that message though from thumb drives that I run through a hub that runs through the back USB 2 panel of the mac.
I’m guessing it’s not the hub though - I use the same hub for the Logitech mouse wireless and my iphone. ¯_(ツ)_/¯ Who knows.

I’ve had this kind of problem with an OWC Thunderbolt hub, albeit TB 2. Also flickering or losing momentarily the second display … in the end, the disconnects went away when I stopped using the hub.

At work I have a CalDigit TB3 dock, but have not had similar disconnect issues.