Does anybody else see this 1Password/Dropbox sync behavior?

1password
sync
dropbox

#1

Here’s a phenomenon I noticed several weeks ago, and it still exists today:

I’m using 1Password 6 standalone version 6.8.9 on macOS Mojave (but the same problem existed under High Sierra) and the latest version of 1Password on iOS on an iPhone X. Sync happens through Dropbox.

When I modify the password for a login in 1Password on my Mac, then leave the “edit” mode, wait for the change to sync with Dropbox, and then open 1Password on my iPhone, the change I just made on the Mac gets overwritten with the old 1Password entry on the iPhone. This happens even when I don’t go to the entry on the phone immediately but first go to Settings --> Sync --> Sync now, and then go to the entry. And it happens regardless of whether I close 1Password on the Mac or keep it open. In fact, when I keep it open while opening 1Password on my iPhone, I can see the entry being overwritten on my Mac right in front of my eyes.

However, when I change the password on the Mac while 1Password is open on my iPhone, then the old entry on the iPhone gets replaced properly. But this scenario is, of course, very rare in real life.

If it weren’t for the “Show previously used passwords” button in 1Password on the Mac, I would have lost the newly created password. This happens reproducibly, and I don’t know why 1Password/Dropbox doesn’t seem to recognize that the entry on the Mac is newer than the one on the iPhone.

Similar situation with notes: I just added a note to a 1PW login on the Mac, and the moment I opened 1PW on my iPhone, a notification from Dropbox appeared on my Mac, saying that I have added a “conflicting copy” of band so-and-so to Dropbox. Same with the username: when I change it on the Mac and then open my iPhone, it creates a conflict copy and 1PW adds a “Conflicts” section to the login that has the new username in there, while the main username field gets overwritten with the old one. I haven’t tested the other login fields, like URLs, etc., and all the field in the various other entry categories in 1PW (bank accounts, memberships, servers, software licenses, secure notes, etc.).

If anybody else happens to be in this situation, here’s a tip: there’s a “Previously used passwords” button in 1PW on your Mac that allows you to recover overwritten passwords. (You can do this in the iOS version, too, but I haven’t verified yet that the overwritten passwords are on iOS as well.)

I had opened a support ticket with 1PW, and they took 1.5 months (!) to get back to me. They referred me to a generic article on how to set up Dropbox sync with 1PW and then wrote:

“Any other syncing issue that’s beyond the scope of the article is beyond our control.”

I have used 1Password for over a decade without major problems, but this does concern me.

Would be interested to learn if this is an absolute fringe case or more widespread.


#2

You might try hitting them up on Twitter.


#3

Thank you for the detailed post.

I tried to reproduce the problem you described but could not reproduce it. Your procedure was followed exactly. Passwords were changed on the Mac, synced through Dropbox, then 1PW opened on the iPhone. No problem - the new passwords are normal on the iPhone and the Mac.

My Mac and iPhone are similar to yours - MacBook runs under macOS High Sierra 10.13.6, iPhone Xs Max runs under IOS 12.1. 1Password 6 (licensed standalone version, not subscription) syncs with Dropbox.

For now I will continue to use Dropbox sync with 1PW but will check carefully after changing passwords. Both 1PW and Dropbox have been rock-solid for me for several years.

A few years ago there was a temporary but widespread problem with iCloud sync, and 1PW users were advised (by Agilebits, the 1PW developer) to sync with Dropbox or with wi-fi for a short time. Since then iCloud sync has improved and is considered relatively stable.

Just in case the problem might be with a corrupted Dropbox installation rather than 1PW, here is one possible solution to your problem: try deleting, then re-installing the Dropbox app on your devices. Check with Dropbox support for the correct procedure, including re-booting the computer. Do the same for the iPhone. Your Dropbox data including your 1PW vault should be safe, as the data is stored on Dropbox servers.


#4

Just a remark:

Have you discussed this with 1password support? It feels like something you should take up with them, and not mention on external forums? (but that might be just me)

It seems like an edge case, and as long as I’ve used 1p I have never seen this behaviour. Nor am I able to reproduce the behaviour now.

If it is related to your setup, your internet connection, your dropbox install, your time settings on your devices, or any other factors that might influence the behaviour, I feel it is a bit early to call it a bug, and put it on this forum. Especially if you have not even contacted 1password to help you solve the issue,

In my experience they are really fast in their support, and stay with you until it is solved.
So I would ask to call them and maybe you can let us know how you got on?


#5

I don’t like these kind of panicking posts. Either ask for confirmation on this forum (or any other forum), or file a bug with the developer.
This sounds like a dropbox issue (not even a bug) by the way.
And I assume you have a backup… :wink:


#6

I also was not able to repeat this issue. FYI I sync via iCloud, so as @vco1 suggested this might be an interesting Dropbox edge case and not strictly a 1P issue. I think it’s reasonable to contact tech support and report back here on a problem, or to ask people here if they also have had a similar issue but here it does seem a bit more like a ‘panicking post’.


#7

As I said in my post, I had contacted them. They took 1.5 months to reply, said any sync issue beyond the scope of their generic Dropbox setup instructions is out of their control, and then recommended a 1PW membership to solve the problem. It was only then that brought this up here in the forum. Fair enough?

But other than that, I have only ever had good experiences with their support, too (for the 2 or 3 times that I’ve contacted them in the past 10 years). They’re one of my favorite companies.

As far as calling it a “bug”: fair enough - I have edited the post accordingly.

Thanks for trying to reproduce this and letting me know that you don’t see this behavior - I really appreciate it!


#8

I see your point, and I’ve edited the post to avoid that impression. By the way, I, too, believe this is a Dropbox issue primarily. We’ll see.

One word about the intention, though: I don’t know about you, but there are few data, if any, that are more critical than the data I keep in 1Password. And at least for me, the issue I’m describing is 100% reproducible. So, the intention of my post was to let other users know about this, so they can decide whether they want to check for this phenomenon and take the appropriate action to fix it.


#9

Hi @bowline, thanks for checking if you can reproduce this issue - I very much appreciate it.

Point well taken, so I have edited the post accordingly, and I’ve also moved it from “Software” to “Tech Support” to ask others for confirmation. I agree, as you and @vco1 have said, that this would have been a better approach to begin with :slightly_smiling_face:


#10

Hi @Arthur,

I have been crazy busy over the past two months, so I haven’t spent time here on the forums. But now that I have a little more time again, I wanted to come back and say: thank you so much for your thoughtful response! My original post was surely suboptimal in wording and choice of category, and yet: not only did you not criticize or condemn, but you even thanked me for the post, tried to replicate the phenomenon, and then proceeded to give some thoughtful, practical advice. I just wanted to be sure you knew how much I appreciated that. Thank you again.