Drafts Window Stays in Front

Something has changed recently that is keeping my Drafts window on top of all other windows. To see what is behind it I have to move it or minimize it. This wasn’t the case until recently. I can’t find a related setting. Does anyone know how this is configured so I can turn it off?

Turn this off in the Window menu.