Dropbox, Hazel, and permissions

Dropbox has forced me to upgrade to their new macOS version that moves the Dropbox storage from ~/Documents to ~/Cloudstorage. This has caused a problem with Hazel.

I have several rules that move a tagged folder from a folder within Dropbox to my NAS. That is move, not copy. But the move is failing. The folder gets copied, but doesn’t get deleted, which means the Hazel keeps making copy after copy.

The new Dropbox location has forced apps that access Dropbox to update their permissions (I get a dialog when I launch the app). But Hazel has not. I would manually give the permission to Hazel if I could find it within the terrible new System Settings on Ventura.

Any pointers, suggestions, or clues would be appreciated. Thanks.

Based on symptoms, it might be that your Dropbox folder(s) is(are) “offline” so that when Hazel tries to do something to a file, the file not there. Just a hunch.

I went thru the same Dropbox change, and today for Google, and all I had to do was change the folder Hazel looks at, and change to “offline” for everything. These changes by Dropbox and Google sync services appear to be caused to maintain compatibility with Apple’s instructions or something.

1 Like

Good thought, but I have manually designated them to be downloaded.

To clarify, the folders are set to be “offline” ? (you are using different words than Dropbox uses so I am asking)

Also check Hazel permissions. For me I granted Hazel to have Full Disk access. Their documentation and/or FAQ may specify other permissions needed. Best to check befor waiting for Hazel to ask.

Yes, I have all the folders set to “Make available offline.” And Hazel has Full Disk Access. What’s needed is to somehow trigger the inter-app permissions between Dropbox and Hazel. For example, when I opened a file in Audition for the first time, it asked me to give permissions to access “Dropbox”. Hazel isn’t doing that.

Okay, so I tried turning off Full Disk Access for both Hazel and it’s engine (listed in System settings as 86Z3GCJ4MF.com.noddlesoft), opening the Hazel app which asked for permission to access Dropbox, then going back and giving both those apps Full Disk Access again, still couldn’t delete the folder in Dropbox.

So I tried leaving Full Disk Access off. Still no good.
I tried leaving Full Disk Access off for the app, but on for the engine. No good.
Full Disk Access off for the engine, but on for the app. No good.

I have emailed Paul Kim at Noodlesoft, but his response so far was to move the Dropbox hierarchy back to the Home folder, but this version of Dropbox won’t allow that. I’m at a loss here. This is a huge part of my workflow and to lose it would suck.

To follow up, the problem had to do with Hazel being unable to transfer the metadata. Paul at Noodlesoft sent me an alpha with some changes that fixed it. Hopefully a release version will be available soon with the fix.


Dom I know it’s been a while, but are you still having the same issues with Dropbox? I have a very simple hazel rule running to delete (move to trash) old folders from within a dropbox subfolder and Hazel just gives me the ‘hazel could not move the file’ notification whenever it runs. It’s basically the only thing I use Hazel for so it’s incredibly annoying it doesn’t work.

No, that problem was fixed by the next version of Hazel. If you’re having a problem, I encourage you to contact Paul at Noodlesoft. He’s very responsive.