Errors installing macOS Monterey Beta

I’ve been trying to download the macOS Monterey beta, so I can install it on a volume on my MBA (M1). I’ve tried multiple times, to no avail.

My machine sees the Monterey beta just fine, but when I try to download it using system preferences, the download gets to 11.73 GB of 11.73 GB, sits for a bit, then aborts with this not very helpful dialog:

Installation failed. An error occurred while installing the selected updates.

When I hop into iTerm and run softwareupdate --fetch-full-installer, all initially looks good. I see Scanning for installer, and I then watch the installation get to 90%, and pause. After the pause, I get this even less helpful message:

Install failed with error: Installation failed

I’m currently running the 11.5 beta (20G5052c), which is what the MBA first decided to update to when I enrolled it in the beta yesterday.

Has anyone else encountered anything like this? Any ideas would be most welcome!

Enough free space you the MBA-SSD?

Plenty. Over 800GB left on a 1TB SSD.

I’ve seen this once last year and again this year. What helped for me at the time was: remove beta profile, reboot, reinstall beta profile.



I’d tried that yesterday, to no avail.

At this point I’m thinking there may be some sort of issue on my dad’s Eero network. Speeds are great, but streaming devices sometimes don’t want to download apps (though they stream content without issue), and I’ve been getting the occasional LibreSSL error: SSL_ERROR_SYSCALL, errno 54 when trying to update packages via Homebrew.

A couple of hours ago I picked up a USB-C to Ethernet adapter and a cable, and the update is moving right along. ¯_(ツ)_/¯

1 Like