Excel Office 365 Copying Slow

Has anyone experienced slowness when copying cells in Excel Office 365?

Originally, I thought that it was because I was using a 2012 MacBook Pro but I recently upgraded to the latest MacBook Pro with 32Gb of ram so I now know that it can’t be the computer.

In small spreadsheets, the issue is not noticeable but as soon as I am using a spreadsheet which is, say over 2Mb, there is a considerable lag when trying to copy anything. On very large spreadsheets, I will even see a spinning ball.

The issue is very easy to replicate:

  1. Open a new workbook
  2. Create a sequence from 1 to 80 in row 1
  3. Copy row 1 to all the rows to about row 22,000
  4. This will create a workbook of about 5Mb in size

Now try copying any cell or cells and notice that there is delay until Excel will allow you to paste the copied cells into another location.

Like most here, I run a lot of utilities such as Alfred 4. I have tried the test after quitting Alfred and there may be a slight improvement but there is still a significant lag.

I would be interested if anyone has experienced this issue and managed to solve the problem.



1 Like

Yep. Doesn’t seem to be a solution. The first copy is always ridiculously slow.
There’s more discussion here on the forum that you can search for.

Yes, it definitely is an issue. And it did not start with Office 365. I have experienced the same with Office 2011.

I have no solution to prevent this from happening. It is annoying.

It is astonishing how much better Excel works on Windows. I do not get why Microsoft is not able to deliver an experience that is as good on the Mac like it is on Windows.

I think that many Mac users do not realize that Microsoft Office on the Mac is still subpar in comparison to its Windows counterpart.

Same delay on Windows.

1 Like

Well, I have no delay with the Windows version. Neither at home on my Windows 10 VM, nor in the office on a Windows 2016 Server. :wink:

I’ll have to double-check then. I’ve been switching back and forth on students’ laptops in my lab section and may have missed a trend.

Yes, this is a known issue with Excel for Mac. There was extensive discussion of this a few weeks ago on the forum. See link below. Note that despite the post title it is not necessarily to do with KM, Alfred or Copied.


I have just checked it with a Wiindows 10 VM and there is no delay.

Thanks for the link. I have turned off Excel in the clipboard history in Keyboard Maestro and it has made a big difference.

Thank you.

1 Like