External Drive Format Issue

(Using monterey 12.3.1 on M1 MacBook…)

Yesterday, I took out a new external SSD drive and formatted it with disk utility and then proceeded to create a new Time Machine backup on the drive.

I first noticed that although the time machine was in progress that the main window the SST was blank. I left for a while and when I came back Time Machine had completed add the window was still blank.

I tried to throw a text file on the drive end it was rejected.

When I got info on the drive - I saw that it was 80% full from time machine - but also that the sharing permissions said read only and there was no lock add the bottom to change the info.

I also noticed that I must have accidentally formatted the drive as APFS (case – sensitive) and maybe that has something to do with it?

Running disc first aid show that everything was working fine. Also I was able to add another test volume as normal APFS - and everything here worked as expected.

Q: normally I would always format as Basic APFS not case – sensitive. My question is why did this drive show up as read only? Why did this drive not have a unlock Choice under get info so I could make changes?

I will be reformatting the drive again as basic APFS but curious what you think abut all this.

Thanks dave

You don’t say how big the external drive is or how much data you have to backup. Case-sensitive not usually recommended for Apple Mac drives. See Types of disks you can use with Time Machine on Mac - Apple Support

You can plug a new drive into your Mac and Time Machine will offer to format it for you and let you check the encrypted option (recommended) if the drive is not already in the recommended APFS format. At this point you’ll probably have to use Disk Utility again if you want to reformat it.

Adding another file is not a good test. You would have to add another APFS volume as the entire current volume is reserved for Time Machine.

What is the actual volume layout on that disk? A screenshot from Disk Utility would be very useful.
Generally, if you have an empty drive and configure it for Time Machine it’ll only have one container and one volume inside it. That volume will always be case-sensitive as that’s what Time Machine uses. With HFS+ Time Machine it was possible to store files on that volume (partition really). APFS Time Machine does not allow it at all – it’s solely intended for TM backups.
If you want to store files on that disk then the best option is having an extra volume within the same container. You can add it using Disk Utility.

1 Like

All of the spinning hard drives I use for Carbon Copy Cloner backups are formatted as APFS or APFS (encrypted). The spinning 2TB hard drive in my 2018 Apple Time Capsule has a GUID partition map formatted as APFS (case-sensitive) and is encrypted by Time Machine.

Things have changed. It wasn’t long ago that APFS was not recommended for spinning hard drives and that Time Machine required its drives to be formatted as HFS+. Not all documentation on the web has kept up with these changes. :slightly_smiling_face:

1 Like

I have some spinning drives and personally I have used APFS on them ever since I returned to the Mac (M1, Big Sur). I have found the features to be too useful and I have always taken those recommendations against with a grain of salt. Even if performance was worse, the file system is way more modern and is generally more flexible and easier to use. And HFS, even with those further developments, was a really old filesystem. It was certainly not designed for terabytes of data scattered across millions of files.

1 Like

Hi. Thanks for the info. The drive is 1TB and the data was about 800 less than the limit.

I added a simple text file that proved it was read only…

yes I should have but already reformatted it - oops…

I am still curious why the TM window was blank? Also I could enter time machine after completion - but window was also blank.

You can still screenshot Disk Utility with your external drive plugged in and selected. Also screenshot the Partition tab. And I don’t know what “window was blank” looks like.

Edit: Does it work now after the reformat?

1 Like

yes DRIVE seems to be fine but did not try TM yet.

And “window was blank” just means there was no data at all in the folder - just completely empty.

ok here’s a pic of the DU After reformatting BASIC APFS.

Thanks. I’ve found mention of encryption and case sensitivity only on the Partition tab, so if you’re interested you might want to look there.

My experience of formatting a multi-TB spinning disk as APFS was terrible. I found the drive to be incredibly slow when populated with large numbers of small files and tracked this down to the way APFS works in a non-linear fashion more suited to SSDs. It would take sometimes minutes to load up thumbnails of a hundred or so JPEGs in a directory, and opening a directory of movie files and expecting thumbnails was an exercise in futility.

I think things must have changed (improved) although I can only point to my experience using cheap 1TB and 2TB spinning hard drives formatted as APFS and used to make daily and weekly backups of my Mac with Carbon Copy Cloner.

1 Like

Yes, performance of spinning drives with APFS is now good. My 8TB spinning HDD used for Time Machine backups is very fast retrieving files, even large 20-40 GB video files. These files can even be viewed and “scrubbed” without dropouts directly from the HDD using a video editor (Quicktime, Final Cut Pro).

The initial setup of a backup drive using Time Machine will format the drive as APFS (Case-sensitive).
[edited to add: … with permissions set to Read Only]

1 Like

Backups are a different prospect to general use data drives. Try putting it to work as a general storage volume with lots of files you trawl through and want to see thumbnails for. Just opening a folder (which causes the OS to read all the files for thumbnailing) was an exercise in frustration.

Clearly there is a discrepancy between your experience and mine. Could it be related to the characteristics of our individual disk drives or connection type?

My drive is a Novus 8TB USB 3.1 Gen 2 Type-C, connected to a Mac Studio USB-C port. This is a 3.5" 7200 rpm desktop-type external drive. This drive is one of those recommended by Mike Bombich, developer of Carbon Copy Cloner software (see link below). After your post describing problems accessing files I did a brief test of a folder in my external drive containing 244 photos, each about 2 - 3 MB in size. I displayed each of the images (using Finder app Quick View feature) as rapidly as possible, manually tapping the down-arrow key. This took approximately 40 seconds (6 images per second) - each image was displayed in full size. I repeated the rapid-viewing test by holding down the down-arrow key, essentially auto-scrolling through all 244 images. This took about 20 seconds.

Link to 8TB HDD: https://www.bhphotovideo.com/c/product/1444555-REG/oyen_digital_3n1_c_8t_bl_novus_3_5_8tb_usb_c_usb.html?sts=pi&pim=Y
Link to Bombich Software disk drive recommendations: https://bombich.com/kb/ccc6/choosing-backup-drive

The Bombich blog post warns against certain types of spinning HDDs: those using SMR technology (Shingled Magnetic Recording) and the ubiquitous 5400RPM Rotational HDDs, aka “Slim”, “Portable” or 2.5" hard drives commonly sold in big-box stores and Amazon. Those slowest-of-the-slow hard drives are not well suited for use as APFS-formated external drives.

Of course SSDs are much faster, but certain types of spinning HDDs can be fast enough for general or backup use if the drives and connection types are chosen carefully. My view is that SSDs are preferred for capacities up to 2 or even 4 TB, but HDDs can be appropriate (and fast enough) for higher-capacity storage needs.

1 Like

My drive is one of those slim/portable drives — a 4TB WD My Passport which I still run as my only external, non-TM HDD. It’s in HFS format and does not seem slow at all in general use (notwithstanding everything else in my setup bar TM is SSD).

Currently, I am trying to format my new 4 TB WD My Passport, I think it’s the same one you have. At first, attempted to do format it via APFS and left it to do so overnight. That unfortunately didn’t complete. Decided to quit Disk Utility and instead reformat the empty drive to Mac Journaled (this should be HFS, right?). Currently, as seen by the screenshot it’s still formatting and that was 10 min ago. Headed to shower and get read for work to see if anything might change.

Hmm - Whenever I format a drive it aways is fast - about 1 minute or less.

but I usually choose FAST = Security Options

You might try: shut down Mac - remove all external devices - restart - then attach just this drive * with a different working cable * - then try to reformat again.

If it is still slow - maybe there is an issue with the drive?

Also can you try formatting on a different computer?

So I let it run while I was at work today. It formatted in HFS (I think) Mac Extended Journaled. I’m fine for now not formatting in APFS, though I think once I change my other external drive I’ll look into it further.

1 Like

OK good. How long did it take?