External monitors switch on waking

Hi all,

I have a 2019 Intel Mac Mini. Generally really pleased with it save for one recurring issue which really bugs me. I’ve spent hours looking for the answer but I just can’t nail it.

I have two monitors.

When I wake my Mac up they occasionally switch round. This is particularly frustrating as I have one of the monitors set up a certain way as my secondary monitor off to my left. It doesn’t happen every time they wake. I will then go a couple of weeks without it happening at all and then it will happen every couple of days. There doesn’t seem to be any logic behind it.

Can anyone help with why this might be happened? And what I can do to stop it?


1 Like

how are the monitors connected to the Mac Mini?

They are connected directly (not Daisy-chained) using uni USB C to DisplayPort Cable (4K@60Hz, 2K@144Hz), Thunderbolt 3 to DisplayPort Cable.

Does that provide enough information?

Thanks for replying.

I think it’s because they have the same ID. I don’t know how to fix it, though.

I have the same thing with a couple of monitors connected to a MBP via a Thunderbolt dock and it drives me nuts.

The only thing I’ve found of use so far is this page on the Mac Rumors forums: My Mac forgets my dual monitor arrangement! | MacRumors Forums

The display placer program that’s linked to from that page seems to offer the option of at least correcting things with a keyboard shortcut (as opposed to manually fighting with display preferences) when it does goes wrong rather than preventing it from going wrong in the first place.

I’ve not tried this myself as I wasn’t keen on installing 3rd party stuff to fudge a workaround, I still hold out hope that one day I’ll find a proper fix.

Since my last visit to that page, there’s been some comments added about turning off auto-switching of display inputs - I’ve just done this on my monitors but too early to tell if it’s helped (my hopes are not high there).

If you do find anything further, please report back, I’d be interested to know! Cheers & good luck. :slight_smile: