Fiber and eero speeds - still having problems

I posted a related topic here: Connect eero directly to ONT? - #9 by neonate

Home networking is a topic of which I know only enough to get myself into trouble. I’ll try to not bore you with all of the details.

I have 1 Gbps fiber internet provided by my local utility company. They use a Calix ONT and Modem/Router. My speeds are pretty good but I wanted to reach an area of my house where I want the speed to be a little better. I bought a eero 6 Pro 3 pack. I tried the following connections: 1) to the Calix Modem/Router (not bridged) 2) directly try to the ONT 3) to the Calix Modem/Router with the eero in bridged mode. In each case the speeds as initially reported by the eero app were ~950/950 (D/U). After about 10 minutes the speeds as measured by the eero app went down to ~815/45 and never returned to the 950 range. The speeds on my ethernet-wired Mac mini were initially ~950/945 but decreased to ~600/40 range after about 10 minutes. When I just used the Calix modern/router (w/o the eero connected), I was getting consistent speeds on my ethernet-wired Mac mini of ~940/940. I called my service provider today and the tech suggested that I factory reset and attach one eero directly to the ONT and see what happens. The tech said they did not do anything on their end from preventing me from connecting any router to their ONT. The tech was extremely empathetic. After doing what he stated I am having the same problems.

My questions:

Why do my hardwired speeds decrease once I started using my eeros?

Is there any setting on the eero app that I could set to fix this problem?

Any help is appreciated.

I would open a ticker with Eero about it. I just upgraded to the same Eero and I’m seeing full speed on my cable connection. Getting better speeds than my 1st gen Eero setup.

1 Like

To be clear, your download speed degraded about 15% after ten minutes and the upload degraded about 95%? And it happens no matter what computer you plug in, or which of the three Eero units you plug in? What kinds of speed tests are you doing? Is there anything that could be periodically interfering with the cable or connection or causing heat problems?

The only Eero app setting I can think of is ‘optimized for gaming and conferencing’ in Discover > Labs. Otherwise it’s hard to say, assuming you’ve demonstrated the issue is independent of one particular unit or computer, and you probably do need to contact Eero support.

Yes. I’ve actually narrowed it down to 10 minutes. I did speed test at 7, 8, and 9 minutes after a restart and they were fine. At 10 minutes speeds goes down.

And it happens no matter what computer you plug in, or which of the three Eero units you plug in?

I’ve only tried it with 2 of the eero units.

What kinds of speed tests are you doing?

I use the Speed Test on the eero iPhone app and Speedtest.net on my Mac mini (ethernet). I also tested using Speedtest.net on an Apple TV (ethernet) - same results.

Is there anything that could be periodically interfering with the cable or connection or causing heat problems?

Cables seem to be fine. I tested multiple cables. Only heat is from the eero, but doesn’t seem excessive. The eero is on the top shelf of a book case in the open, in an air-conditioned room.

I will try the setting in Labs that you described. I sent an email to eero support as suggested by you and @glenthompson. Thanks for your help.

1 Like

Definitely let us know what you find. Narrowing down to ten minutes suggests to me that some kind of status is expiring, but I don’t have any way I can test this on my network.

I agree. Some people don’t like eero because there is not much customization. Will keep y’all posted.

Still having problems. Here is a synopsis (updated and more extensive than my original post). Will contact eero and ISP support again tomorrow. Anyone see anything here that I could try or that I could ask of the support people. This has been a very frustrating experience. Any help is appreciated.

Network equipment
Fiber to my house is provided by my local utility company and I have the 1 Gbps plan.
ONT - Calix GigaPoint 803G
ISP Router - Calix GigaSpire GS4220E
My Router - eero pro 6

All of the above have up-to-date firmware.

My goal
I want to have a home mesh network using eeros. The gateway eero will be directly connected to the ONT. I want to use eero secure.

Current configuration
ONT connected to eero by a cat-6 ethernet cable. Nothing is connected to the Eero’s second ethernet port. The ONT was powered off for 5 minutes, then restarted. Once all of the appropriate green lights on the ONT were lit, I plugged in the eero. The eero had been factory reset before doing this. I created a new wifi network on the eero. The only devices on the wifi network were an iPhone, Mac mini, and an Apple TV.

The problem
Speeds as measured by the eero app (which is the speed that the eero receives from the ONT) is in the 950/950 (D/U) range for the first 10 minutes. Then it decreases to ~600-800 down/35-50 up). The speeds never return to the starting values. This problem has been reproduced countless times over the past week.

What I know works (solid network - speeds in the 950/950 range - no speed decreases )
A network using the ISP’s router connected to the ONT. Speed measured by my Mac mini via ethernet.

A network using the ISP’s router connected to eero (with the eero in bridge mode) to the ONT. Speed measured by the eero app as well as by my Mac mini via ethernet.

What I have done

  • Powered cycled ONT and eero (numerous times).
  • Restarted eero network via eero app (numerous times)
  • Changed the ethernet cable connecting the ONT to the eero. (numerous times)
  • Direct connected my Mac to the ONT via ethernet. Speeds were 950/950 and never decreased.
  • Toggled IPV6 on and off
  • Tried different DNS (Google 8.8.8.8)
  • Checked speeds at 1, 5, 6, 7, 8, 9, 10, etc up to 13 hours after restarting network. Speeds were always fine up to the 10 minute mark then decreased.
  • Alternated contacting ISP support and eero support
  • ISP had a crew come to my house and evaluate the line. They did notice a kink and replaced a large section of the fiberoptic cable both in my house and at the outside box. (The ONT is located inside). The said the GPON was -19db (which they said was good).
  • The ISP said they did not do anything to prevent anyone from using whichever router they wanted. There was no setting that they would have to set to allow you to do so.
  • Eero support was on the phone with me while I restarted the network and measured speeds. They were fine until the 10 minute mark, then decreased. We did this twice.
  • Eero support had me send them a photo of where my network devices are located. The networking gear is out in the open on the top shelf of a bookcase in an air-conditioned room. They said that was fine.
  • Eero support has escalated up one level. Agreed to check back with then once I did the things listed in the next section.
  • At this point we are at the inevitable point of eero thinks it’s the ISP’s fault; the ISP thinks it eero’s fault

These are the things I have done since I last spoke with the ISP/eero support

  • Left the network on for > 12 hours to see if something magical happened between 4-12 hours (new DHCP lease or whatever)
  • I bought, for testing purposes (and plan to return), a TP-Link AX1800 4-stream dual-band Wi-Fi 6 Router. I connected this directly to the ONT and created a new network. This worked fine with speeds 950/950 that did not decrease after 10 minutes. So the ISP does allow non-ISP routers w/o any configuration on the ISP’s part.
1 Like

Great writeup! Isolating the cause to the Eero specifically with that TP-Link router makes this just about impossible to investigate at from outside the Eero organization, at least at my level of knowledge. I hope they’ll seriously dig into it and patch (assuming they don’t conclude your specific units are faulty.)

Thank you. Gotta add that to my report (which I’ll share with eero and ISP support). I did factory reset and tried all of this with all 3 of the eeros that I own.

When the Eero is connected to the ONT are you using just the built in Eero speed test or a speed test on your computer? Wondering if the Eero speed test has issues after 10 minutes.

Thanks for the thought. I’ve been doing both with the same results. I had my ISP clear out my DHP and reset the ONT today. Still had the same problems. ISP support has now done all they can/will do. Next step to contact eero support again. Heard some reports of isolated weirdness with the latest eero firmware update in July, so maybe it’s related to that.