Fonts in Messages


#1

Very annoying and not very important glitch: I can select the font for text on my home computer (MBP) and one work computer (MIA). I am NOT able to select it for my iMac in my main office. All are running the same operating system. Any ideas?


#2

What do you mean by ‘select’? I’ve never found a way to choose a different font in the Messages app on my Mac. Or do you just mean select text from a message?


#3

No, I didn’t mean within messages. On both laptops, I can select the display font in preferences. I cannot on the iMac in my office.


#4

Which preferences, where?


#5


The preferences in Messages.


#6

That’s new to me! I’m running NMojave 10.14.3 and I don’t have those options (and don’t think I ever did on any previous OSes either):


#7

I’m running it on all three computers but only can adjust on two.


#8

I’ve got quick access to Sierra, High Sierra, and Mojave systems here and none of them look like violagail’s screenshot! High Sierra and Mojave have the Text size slider. Sierra has the ability to select the font and AppleScript handler but Sierra (and High Sierra) also allow selecting the default IM application.

Anyway, it looks like the ability to select the font was removed. Sierra version:

Server2
High Sierra Version:
General-3
And on Mojave, just like bowline’s.

Added: I’ve also got a system running El Capitan. It’s different still, with the text size slider and the AppleScript Handler.
LR_Computer


#9

I promise I’m running Mojave on the laptop from which I sent the screenshot :slight_smile:
I am very font sensitive and like being able to pick the one that’s easiest on the eyes!


#10

It seems the option to choose the Messages font only appears when the ‘Reduce transparency’ option is enabled in the system Accessibility preferences.

Unfortunately the Messages preference will also only be honoured with that enabled. If disabled, the next time you restart Messages, it will return to using the system fonts.


#11

Wow, that’s a tip for the ages! With that trick I just switched my iMac’s Messages font from System_13 to Consolas_19, now much more readable. Many thanks.


#12

I’m rather pleased to find it myself, having gone looking for a way to do it a couple months ago.

(Greetings from Mie!)


#13

Great tip—now, if I could just figure out how I did it on 2 computers not the third :slight_smile: I’m out of town now but look forward to changing the settings on my office computer!


#14

Sure enough! The system (running Sierra) I had, the only one showing the font selection option, also had Reduce Transparency checked. Not really sure why it was checked.