Forced to subscribe to a google calendar but can't

Everyone here knows my aversion to cloud services.

However for a specific project I have to subscribe to a google calendar that I have read and write access to. I looked at the calendar via safai, looked at the permissions and got the Public URL to the calendar. Tried in iCal to subscribe but get an error message that " There was an error subscribing to the calendar. and the details are there was invalid data.

I did not create the calendar but I did subscribe to it via my gmail acount.

It’s not a public access calendar though.

Is there something I am doing wrong or does the person who created it need to set something so I can get it into my iCal system? I’ve tried to follow the various instructions on the web but I never see the secret .ics link anywhere that some places say is the properlink to use in iCal.

My aversion to cloud systems means I am totally clueless on this problem.

Somehow I’d think it would be as simple as checking the Calendars box in System Preferences → Internet Accounts → Google.

It should appear in the Calendars program.

1 Like

Tried that, but I can’t get the Google calendar included. I don’t use iCloud for my calendars at all.

Ignore iCloud, I just didn’t obfuscate the entry. If you set up the Google account in Internet Accounts and check the Calendars box then all Google calendars should appear among your calendars. I don’t use Google Calendars but seem to have some. When I check that box the Calendars program shows this in the left column:

So it’s bringing in a bunch of calendars. It seems to pretty much match whats in the list at but for Birthdays Reminders and Tasks which don’t show up on the Mac.