Getting Alfred to Recognize Bike Outline Files

Hi All,

I just started using the outliner app Bike. One of the biggest points of friction is Alfred doesn’t recognize the file format “.bike” so I can’t use Alfred to open specific .bike files.

I tried moving the .bike files to folders that are “monitored” by Alfred and I tried re-indexing but I can’t seem to get Alfred to see and open Bike files.

Can anyone help?

Ask on the Alfred forum?

You might try the standard method of telling the file system which app opens which file types. Select a .bike file in Finder. Click File > Get Info. In the middle of the dialog that appears, in the “Open with” section, pick Bike from the dropdown list, then click “change all”. Alfred should then recognize this new assignment in the file system.

(Bike should have registered itself, by the way. It’s not Alfred’s error.)



Agreed, and to help isolate the issue, check if Spotlight can open the file, too.


Thanks. Super helpful. If everyone used your suggestion, there’d be no activity in this sub-forum.

1 Like

I can open bike files with Alfred without issue.
Alfred 5.1.2
Bike 1.14
Ventura 13.4.1
Are new files being saved with the .bike extension or .opml?

they are being saved as .bike files. Spotlight can find them but Alfred can’t.

Issue isolated as Spotlight can find the files.

1 Like