Gmail (GSuite) Messages Disappear in Mac OS After 2 Weeks

Hello everyone,

Long time listener to MPU, first time posting.

I’ve had a longstanding issue with my GSuite messages and Apple Mail on my Mac. I set up my business email on Google Apps (when it was free) and have been grandfathered into G-Suite’s free option. I’ve long noticed that any emails in any of my GSuite accounts just disappear from the message list in on my Mac. It doesn’t matter if they are in the inbox or a separate folder. Something just happens to them once they are 2 weeks old.

Interesting Notes:

  • The messages are still in the proper location if I log into Gmail on the web.
  • I have an iPhone and iPad and the messages still appear properly in the on each of those iOS devices.
  • I have Airmail installed on my Mac and the messages still appear correctly in Airmail.
  • I also have an iCloud account, and those message do not disappear in on my Mac.

I thought it may have been some Gmail filter or Apple Mail Rule, but I don’t think it is (especially since it doesn’t affect the message on other platforms).

I have two colleagues using and they have the same issue with our GSuite accounts. (Our lone Window colleague does not have the issue.)

I tried setting up a new admin user on my Mac, and when I added the mail account there, it still had the same issue. I’ve done tonnes of online research but haven’t yet found a solution.

Has anyone had a similar issue? Any suggestions? Thanks so much!

Tech Specs:
2018 Macbook Air
Mac OS Catalina 10.15.2 (although the problem was present in Mojave)

1 Like

From what I’ve found, I think this is a setting in gmail that limits the size of the folder synchronized by IMAP. As you’ve seen, it doesn’t affect the number of emails in your gmail account, only the number that are synchronized.

Open gmail in your browser.
Click the gear, then choose Settings.

Look across the top and find Forwarding and POP/IMAP
Down near the bottom is Folder size limits. You can set this to the number of messages you want to download, or set it to unlimited.


That’s it, that’s it, that’s it! I just changed that setting and when I opened Mac Mail, all the old messages came flooding it. Thanks so much, John!! Merry Christmas!


Glad to help! Same to you!

1 Like

Wow! This suggestion helped me now, after 2 years since posted. I’ve been having this problem after started using Apple Mail with G Suite on macOS Monterey, especially after trying to setup some rules for the messages (by the way, I did not manage to make the rules work with the G Suite account, just messed up the inbox, ONLY in Apple Mail).
In my case I did have the “Do not limit…” option active. After seeing your suggestion I switched to “Limit IMAP…” saved the settings and changed it back to “Do not limit…”. Problem solved! Apple Mail Inbox was populated with the messages that were on the Inox in the G Suite Web platform. Hopefully problem solved for good. Unfortunately I will have to revert to the Google web platform every time I want to tinker with the rules and filters for the messages. No way I see to make them work in Mail app.