Google refusing login from iPad Safari - any ideas?

About a week ago I noticed that one of my gmail accounts was no longer syncing across devices. It’s possible it was related to an update as there have been a few recently. I use Apple’s native Mail app across my devices so it took a few days before I noticed that changes I’d made on one device weren’t showing up on another. Mail continued to be retrieved as normal (hence why I didn’t spot the issue), but things like deleting and flagging were only occurring on the device - changes weren’t being synced.

I started digging into this properly today and discovered that aside from not syncing across devices, the changes also hadn’t synced back to Gmail (I logged into my online account to see what was happening). Forcing “synchronisation” didn’t fix the issue, nor did taking the account offline and then back online.

I decided to delete the account from my Mac and iPad first to see if that fixed the issue. On my Mac that’s worked, and the Mail app now matches the web version of Gmail (sadly with none of the changes I’d made, but never mind).

The iPad, which I now suspect was the source of all the trouble in the first place, refuses to comply :face_with_raised_eyebrow: It let me remove the gmail account, but Google now refuses to let the iPad back in. If I login it says the account can’t be verified.

Weirdly, if I sign in to my Gmail account in Firefox on my iPad, it works fine, so the issue specifically seems to be the Safari browser on iPad. I’ve disabled Apple’s private relay in case it was messing something up at Google’s end, but that didn’t fix the problem. I’ve also disabled all my Safari extensions, and that didn’t help either. What should I try next? I’m on the latest OS on all devices.

This currently means only my Mac can access my email. I hadn’t deleted and reinstalled the account on my phone yet because I was doing devices in order of priority, and now I am nervous to delete the account knowing that the iPad has a problem - even if I can’t action emails at least I can read them currently!

Have you cleared Safari’s cache on your iPad? Settings > Safari > Clear History and Website Data

Do you have Screen Time enabled? Is it possible you have an incorrect setting in the permissions?

Try installing on your iPad just to see if that is functioning correctly. If so you can use that while you work on the problem.

I’m not sure Safari is the problem. Have you tried the steps recommended by Google?

And I second @WayneG 's suggestion to temporarily install the Gmail app on your iPad so you handle your email.

1 Like

I figured this problem out, but the answer is quite terrible. The only way I could get Google to sign into my account in Safari was to disable “prevent cross site tracking” and disable “hide IP address”. Once I’d done that, Google recognised the device and allowed me to login.

After I’d done that, I turned both options back on in Safari. My email is still working, but Google won’t let me open any links sent via Google Alerts. I just get a message saying I’ve failed their security checks.

I absolutely hate that Google forced me to disable Apple’s privacy settings just to get into my own email, and Google Alerts are pretty useless when you can’t access the links it finds :roll_eyes:

On the upside, it is making me think about buying DevonAgent instead!

1 Like